Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some trouble installing Imagick on a Mac. I have XAMPP installed and when I run 'sudo pecl install imagick', I get this error:

checking ImageMagick MagickWand API configuration program... configure: error: not found. Please provide a path to MagickWand-config or Wand-config program.
ERROR: `/private/tmp/pear/temp/imagick/configure --with-imagick="/Applications/XAMPP/xamppfiles/bin"' failed

The error above shows up when I input /Applications/XAMPP/xamppfiles/bin after Please provide the prefix of Imagemagick installation [autodetect]

Do I need to install some other library before running the Imagick install command?

share|improve this question
    
Maybe this helps. lists.macosforge.org/pipermail/macports-users/2008-March/… If it did help and you got it to work, write the answer yourself and accept it. –  Darokthar Feb 21 '11 at 22:17
    
Thanks for the link...so I managed to finally install it but I can't seem to be able to load the library. When I include extension=imagick.so and also the path to the extensions folder where the new modules folder was created, I get a blank page in localhost/index.php. Any thoughts? –  Cat Feb 22 '11 at 3:52

1 Answer 1

I would recommend using Brew to install imagemagick instead of MacPorts. Much simpler, imo and less error prone. There is information on the Brew wiki on how to clear out macport installed files so that old installs won't interfere.

On the brew github site, they show you how to quickly install brew. Once brew is installed, you can install imagemagick with brew install imagemagick. Also, keep in mind, Brew was designed to not need sudo. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.