Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently, I've noticed that the dock has been starting to display low-resolution icons in place of the former high-resolution icons for common apps like Stickies, Word, iTunes and Preview. Looking at the .icns file within each program, all copies of the icon are present within the file (high and low resolutions), but the dock refuses to display them, leaving some programs looking like this:

Dock

Restarting doesn't stop this behaviour, nor does a killall Dock, nor removing the icon and replacing it in the dock. In Finder, the icons display normally. Does anybody know what may be causing this issue? Thanks!

share|improve this question
add comment

4 Answers

I had the same problem and this sequence renewed the bad Chrome icon:

  1. Moved com.apple.dock.plist from ~/Library/Preferences (*) to a "temp" folder on my desktop (or move it anywhere you like)

  2. Moved com.apple.dock + com.apple.finder (whole folders) from ~/Library/Caches (*) to my "temp" folder.

  3. Rebooted. This restored the bad icon and reset the Dock to default settingsv (since the preferences were removed in 1).

  4. Moved back the preference file (1) + the folders (2) to their original location (confirm overwrites where asked).

  5. One more reboot and all was fixed.

(*) ~ is your home directory.

share|improve this answer
    
This worked for me. FYI, you don't have to reboot - since the caches are in your home folder, just logging out and logging back in is enough. –  Rufo Sanchez Jan 31 '13 at 22:31
add comment

Try moving the files com.apple.dock.db and com.apple.dock.plist from ~/Library/Preferences (FYI: ~ is your home directory) to a different folder (your desktop for example), then log off and back in.

share|improve this answer
    
Neither of these worked, unfortunately, nor did removing the ~/Library/Caches. Thanks though! –  squircle Feb 24 '11 at 16:25
add comment
up vote 0 down vote accepted

I've found that quitting and restarting Finder resolved the issue for me. Force-quitting Finder didn't work; I had to change the preferences:

defaults write com.apple.Finder QuitMenuItem 1

Then, quitting and restarting Finder (from the menu bar and dock respectively) seems to reset the dock icons once they're clicked again. Although it doesn't seem like a permanent solution, it's worked for me so far.

share|improve this answer
    
You can select to relaunch Finder when Option-Rightclicking its Dock icon. No need to Force Quit. –  Daniel Beck Feb 24 '11 at 18:05
add comment

If I remember correctly, Onyx has a option to clear the icon cache which would probably fix this.

You could also try resizing the dock, first go to the smallest size, then the largest, then back to the size that you want.

EDIT: I downloaded OnyX, and found the dock icon cache that what I was remembering. It is located under Cleaning > User page:

enter image description here

I cannot reproduce your error, so you should try that and see if that helps. I also saw that there was some interesting options under the Parameters > Dock page:

enter image description here

share|improve this answer
    
I looked through Onyx, and a quick google search confirmed that OnyX doesn't have this capability. Thanks for the suggestion! –  squircle Feb 23 '11 at 17:45
    
I am not sure if they added this feature since 2007, but see the above images for what I was thinking about, and see if that helps. –  Alex Feb 24 '11 at 6:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.