Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set an upload limit of 30kB/s, but sometimes it is uploading 100kB/s. I have tested uTorrent and BitTorrent and they have the same problem. I disabled the setting "use more upload slot if upload < 90%". I have set 30kB/s limit both in the current torrent preferences and in the general preferences.

Why does it still use more bandwidth?

EDIT. Found the solution, enable "limit local peer bandwidth, under bittorrent tab"

enter image description here

share|improve this question
5  
Are you sure you're not just confusing kilobytes and kilobits? –  Daniel Beck Feb 22 '11 at 18:17
    
On the other hand, 30kB/s = 180kb/s. –  Olli Feb 22 '11 at 19:00
    
30kB = 240 kilobits, actually. @Olli –  oKtosiTe Feb 22 '11 at 19:14
1  
@oKtosiTe: well, simple multiplications are so hard. And yes, true. –  Olli Feb 22 '11 at 19:16
    
…and with Google’s Calculator –  Synetech Jun 1 '12 at 4:06
add comment

7 Answers

up vote 4 down vote accepted

Check if the upload is going to a peer on your local network.

utorrent, for some reason does not limit the upload rate to local peers, even if a global upload rate limit is set

share|improve this answer
    
Good point. Some providers even distribute Class C addresses to their client, so that might be something to check. –  oKtosiTe Feb 22 '11 at 19:23
    
What do you mean by local network? My ISP acutually uses NAT so do you mean every other poeple with my same ISP? Other than that I don't have any LAN here –  dynamic Feb 22 '11 at 19:27
    
@yes123: I have seen ISP's that give out addresses in the 10.0.0.0 and 192.0.0.0 address ranges. If they do, uTorrent might confuse other users of the same provider with local clients. This is very hypothetical, though. –  oKtosiTe Feb 22 '11 at 19:30
1  
If your router gives you a Class C address, that's a whole different story. I'm talking about the situation where people outside of the network behind your router/modem/outlet would also be represented with 10.0.0.0 or 192.0.0.0 addresses. If they're not, then my comments can be ignored. You can check for this on the "Peers" tab in uTorrent. (Disable "Resolve IPs" by right-clicking there.) @yes123 –  oKtosiTe Feb 22 '11 at 19:43
2  
uTorrent can limit local transfers. You just have to tell it to in the preferences. The reason that it doesn't by default is because it makes little sense in 99% of cases. You typically configure your uTorrent network settings based on your internet bandwidth, but transfers to local peers don't use your internet bandwidth and are usually capable of many times the transfer rate. So why would you throttle your local transfers as if they were internet transfers and turn a 5 min. transfer into an 8 hour transfer? –  Lèse majesté Jun 1 '12 at 4:07
show 3 more comments

Be sure that Apply rate limit to uTP connections is checked in your settings

share|improve this answer
    
doesn't work... –  dynamic Mar 3 at 16:03
add comment

As Daniel suggested, you may confuse kilobytes and kilobits. At least in uTorrent speed is set using kilobytes per second (kB/s).

One kilobyte is 8 kilobits, so 30kB is ~240kb/s. It might be 100kb/s, if there isn't many people downloading it, or if your network connection limits it to slower speed.

Another possibilities are bug in both uTorrent and Bittorrent. Or protocol overhead is really high for some reason. Or finally, if your bandwidth monitor bugs for some reason.

share|improve this answer
    
I don't think uTorrent displays kbit/s anywhere. –  oKtosiTe Feb 22 '11 at 19:16
    
There's no bug in uTorrent and BitTorrent's global upload rate setting. And the bittorrent protocol certainly doesn't have a 200%+ overhead. (Even if it did, the client would still be limiting the TCP transfer rate, which includes any bittorrent protocol overhead.) –  Lèse majesté Jun 1 '12 at 4:01
add comment

My quess is that your 'conspiracy theory' of ISP or BOTH torrent client makers is not possible. What info would they like from you what they could not test by them self. child porn maybe? Just see your µtorrent page connection and put a mark to every four selection and let it choose port by random and my limiter is working as I have set it, no slowness nor errors on torrent or files, even the µtorrent 1.8.4 has been fastest up-loader and dl'r. Not the newest one either. - mmf -

share|improve this answer
add comment

one thing I noticed that fixed upload exceeding limit issue was that the "Apply rate limit to transport overhead" and "Apply rate limit to UTP connections" boxes were unchecked. This must have happended when I went to the newest version, cus I noticed my download speed suffering the very next day. Once I checked those 2 boxes the upload speed went from 300k plus to the 150k I had set. Hope this helps someone.

share|improve this answer
add comment

This is a related issue, but if you're in a situation where you want to limit upload or background bandwidth used one important consideration here is the number of simultaneous connections. You might find you get down to just 30kB/s just fine, but still have issues with your actually throughput because that 30kB/s is divided among 500 or more active connections to different peers. In this case, sometimes a router or modem just won't handle it very well, or it becomes a flag that your isp uses to start traffic shaping or throttling on your connection.

share|improve this answer
add comment

To make sure that the upload limit you set in uTorrent is respected, go to Options > Preferences > Bandwidth > Global Rate Limit Options and make sure that the "Apply rate limit to transport overhead" and "Apply rate limit to uTP connections" boxes are checked/enabled.

This is the answer and solution to your question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.