Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For many years I have used Samurize to display this little gem at the top of my display:

Recently I noticed that the meters for network upload and download were not working, so I went into my Samurize config to make sure they referenced the correct performance counters. Unfortunately the "Network Interface" category of performance objects is missing from the list, along with a few others.

The "Network Interface" category is available in the Windows Performance Monitor. I have tried running Samurize as Admin and I have UAC turned off anyway, but nothing has seemed to help.

I would greatly appreciate any suggestions for correcting this!

share|improve this question
    
To my knowledge Samurize doesn't officially support Win7. Maybe you had a Windows update or something that finally broke it? – Shinrai Feb 22 '11 at 19:06

I had the same problem, and found this solution on the Microsoft support site: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/perfmon-problems-unable-to-add-counters/e90f231d-0014-457d-8b1f-5f342971597a

"From a level your pointers to the perfmon Counters are corrupted, you have to rebuild these with LODCTR from a elevated command prompt:

Click Start, type cmd right click cmd.exe, and select Run as administrator. At the prompt, type lodctr /r and press ENTER. This will repair the pointers (those are stored in the registry).

C:\Windows\system32>lodctr /r

Info: Successfully rebuilt performance counter setting from system backup store

After this action it is possible that some providers are disabled. You can check the status with lodctr /q.

C:\Windows\system32>lodctr /q

If it says (Disabled) next to a provider, you can enable it with lodctr /e:. Use for the string between the [ ] at the beginning of the entry."

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .