Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Scenario:

I am at work. I want to remote desktop into my machine at home. Problem is, my 5-year-old daughter is playing games on Starfall.com (or something similar) on her (non-admin) account. When I attempt to connect I see this message:

Another user is currently logged on to this computer. If you continue, this user has to disconnect from this computer. Do you want to continue?

I click Yes and then see

Please wait for 'UserName' to respond

This presents my daughter with an Allow/Disallow dialog on whether to let me connect. She clicks Disallow (or No or whatever it says) and then I see

'UserName' has denied your request

Question:

How can I force my account to log in and disconnect her session?

Additional Info:

My account is an administrator account. My daughter's account is a non-administrator account. Home machine is Windows 7 Pro with fast user switching enabled.

Note In my case, turning off fast user switching is not an option. Kyle pointed out in his answer that turning it off would allow the admin to force another user off. I'm accepting his answer and it identifies the issue, even though it doesn't solve my exact problem. I need to keep fast user switching's ability to change accounts without closing the previous account's session over being able to force myself to connect.

share|improve this question

5 Answers 5

up vote 4 down vote accepted

Turn off fast user switching, it causes the prompt box to appear for the other user regardless of their group memberships.

EDIT: I could not find anything in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client (or HKCU) that will disable this behavior.

Additional Info: Here's an article from MS on the how RDP acts with and without Fast User Switching enabled, for various user scenarios. It's for XP, but the rules still apply.

share|improve this answer
    
I'd prefer to keep fast user switching on as I don't want to log off existing sessions, e.g., if my wife is in the middle of something on her account and has unsaved work. If it's an either/or scenario, I'll stick with fast user switching over being able to force myself in. Question updated to reflect this clarification. –  brett rogers Feb 22 '11 at 20:17
1  
Short of a hack there is nothing you can do... Good question though I hope someone has a work around.... –  Kyle Feb 22 '11 at 20:34
    
As Kyle said: It's either disable Fast User Switching or apply an RDP hack to allow multiple concurrent sessions (which would technically violate your Windows 7 license agreement with MS). –  Ƭᴇcʜιᴇ007 Feb 22 '11 at 21:07
    
Even though this isn't the exact answer I was looking for (because it sounds like there is no answer for what I want given my context), I'm going to accept this answer because it identifies the issue. –  brett rogers Feb 24 '11 at 19:23
1  
Glad I (and @techie007) could help out, sorry there isn't a fix for this... –  Kyle Feb 24 '11 at 19:26

Try the /admin switch:

Computer: brettbox /admin

(or, on Start - Run:

mstsc /v:brettbox /admin

)

share|improve this answer
    
I didn't think about trying /admin... It didn't work with /console. I thought the two were the same? –  Kyle Feb 22 '11 at 22:01
    
good thought, but already tried it - same result. –  brett rogers Feb 22 '11 at 22:17
1  
@Kyle - /admin is the new switch to use with the newer mstsc.exe (version 6+ I believe). /console was the switch for the older version. –  brett rogers Feb 22 '11 at 22:18

You could try using Concurrent RDP Patcher. Here's a blog post about it:

There is a tool called Concurrent RDP Patcher which is meant to enable concurrent remote desktop connections, which means multiple logons per user. When you log in using the Remote Desktop Connection, the computer that is being controlled will show a message saying “Logged on remotely from COMPUTERNAME”. If you click on the user icon to login, the remote connection will be terminated with the popup:

Here's the original announcement referenced in the blog post. You should probably use some caution, as with all software with unknown origin that patches system files.

share|improve this answer

LogMeIn has a free version of their product that works quite nicely for stuff like this. When you login to your account and then your computer, if someone is on it (i.e. your daughter), you will just share the session.

http://www.logmein.com

Not RemoteDesktop per se, but a good workaround to the issue you describe with no registry hacks necessary. Although, you will need to setup an account and install a plugin on the target computer.

share|improve this answer

I know this is a 2-year old topic, but I have a solution for it: Use Chrome Remote Desktop. You are able to take control of your remote machine and switch accounts without having to use RDP. It is secure and works wonderfully. An added bonus is that you actually see what is going on while you are trying to login, whether it is your daughter or your wife using it, and whether it might be prudent to wait.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.