Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't seem to figure out how to disable the bell when starting an xterm in XQuartz (X11) on OS X. Once my xterm window is up I can use xset -b but I don't know how to do this by default.

As far as I can tell there is no startup option for the xterm command to achieve this (other than visual bell, which I also don't want). I have tried putting the xset command into my .bashrc or into .xinitrc both of which cause XQuartz to fail to open an xterm window.

share|improve this question
add comment

1 Answer 1

In the newest Xquartz, you may write in a Terminal:

defaults write org.macosforge.xquartz.X11 app_to_run /usr/bin/true

Then no more annoying xterm. See http://xquartz.macosforge.org/trac/wiki/X11-UsersFAQ .

share|improve this answer
    
Unfortunately this does not answer the question at all. I am trying to disable the bell in xterm, not disable opening an xterm window when opening x11.app. –  amicitas Apr 15 '11 at 4:52
    
Oooops! sorry! Was doing two things at the same time. Anyway, you can write a script in favorite bin, say, no_bell_term, with the lines: xset -b\n/usr/X11/bin/xterm; make it executable and replace the '/usr/bin/true' by this in the previous snippet. It worked for me. –  Martial Boniou Apr 15 '11 at 20:40
    
@MartialBoniou You might want to edit your question with your updated solution. –  Mark Johnson Nov 24 '12 at 19:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.