Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just discovered yesterday that my D: partition isn't showing up in the Windows 7 defragmenter.

All my other partitions (C, E, F) are there.

The D: partition is running and working just fine - heck I've even got my users folder there, so the desktop and so forth are on it.

Any clues what might cause this ?

share|improve this question
    
You could try an alternative defragmenter, such as defragler. –  MaQleod Feb 23 '11 at 6:27
    
True I could, however I'm rather certain the partition being missing is just a symptom of something else. And it's the "something else" I want to fix :-D –  Steffen Feb 23 '11 at 6:52
    
You should upgrade to third party defragmentation software, the windows 7 in-built is good but it is also limited. –  user70038 Mar 3 '11 at 17:04

1 Answer 1

up vote 2 down vote accepted

Force a CHKDSK on that partition and reboot. It may have a dirty bit set and needs to run a scan to make sure defrag is safe.

share|improve this answer
    
+1 Will try it as soon as I get home. –  Steffen Feb 23 '11 at 7:34
    
chkdsk -R did it :-) –  Steffen Feb 23 '11 at 20:00
    
Glad to hear it! –  user3463 Feb 23 '11 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.