Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem installing applications on Windows 7. I keep getting the error

This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package.

I have downloaded the right packages for iTunes and Google Earth but they just wont install

share|improve this question
    
Do the event logs give you more information? Can you create a log file with Process Monitor and check if there are ACCESS DENIED (just CTRL+F for DENIED) events (or upload so we can check for anything that's weird)? –  Tom Wijsman Feb 23 '11 at 14:16
add comment

4 Answers

I had a similar issue on a recently built machine (Win 7 64-bit) and it turned out to be faulty RAM - the machine was generally stable with the odd glitch, which I put down to not having all the system board drivers installed yet, but it really started to behave badly when I ran any installers. The fix was to replace the RAM.

share|improve this answer
    
Ive checked both pieces of RAm and they have no problem –  Gatura Feb 23 '11 at 14:12
add comment

You don't say which version of Windows 7 you are using - 32 bit or 64 bit.

Make sure that you download the correct architecture version of the installer. If you are on 32 bit Windows make sure you install the 32 bit version of the application. It shouldn't matter which one you install if you are on 64 bit Windows, but it would be better to install the 64 bit version.

Given that you've checked and installed these then the next obvious thing is that the download is corrupt. Re-download the installer and try again. It seems unlikely that two installers would be affected in the same way though.

share|improve this answer
    
Am using a 64 bit, which is what i donwload, nothing seems to work. ihave made sure i have downloaded for the correct architecture –  Gatura Feb 23 '11 at 11:50
add comment

My guess out of the blue, Downloaded and directly started from Firefox, did you leave FF open? - cause it will remove temp files when closed.

share|improve this answer
    
I downloaded from one machine and then went to install on another –  Gatura Feb 23 '11 at 14:13
add comment

Maybe you need a new version of the Windows Installer, but they don't seem to be available for Windows 7.

Or you could try to go through this knowledgebase article.

share|improve this answer
    
Which would be for windows 7, I have tried them but none is working –  Gatura Feb 23 '11 at 14:12
    
I updated my answer –  slhck Feb 23 '11 at 15:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.