Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay, so I have a Gateway laptop, with Windows Vista SP2, and a Linksys-Cisco WRT54GL Wireless-G Broadband Router. When I boot up my laptop, it automatically connects itself to my home network. Then at random times, it disconnects itself from said network. I go to reconnect it, but I get an unknown error and none of Vista's suggestions are working. Sometimes, after 5-10 minutes, it will reconnect itself. I've already tried updating the firmware. I can't install any other firmware, or make a factory reset. My dad owns the router and buys the internet and he won't let me TOUCH it. I can't do ANYTHING to it.

share|improve this question

Before you go messing with the firmware, have you tried to check for simple things that might be causing the problem. I once had a cheap baby monitor that kept kicking my laptop off the wireless network. Often times a cordless phone can also have this affect since the phone and the router both operate at 2.4GHz. If those aren't the problem, then a possible firmware update might be in line. However, if I was going to use an aftermarket firmware, I would definitely use DD-WRT instead of Tomato.

share|improve this answer

Sounds like a factory reset on the router and a reinstallation of the adapter.

share|improve this answer

You may want to do a factory reset on your router and see if there are any firmware updates available.

share|improve this answer
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. – Diogo Aug 9 '12 at 13:50

There is the option to try changing the firmware on your router, I run a Belkin router with DD-WRT, but there's also OpenWrt to consider.

Another possibility, especially if the issues occur after your computer has been in sleep/standby, is to disable power management for your network card.

Right-click 'My computer'
-> Device Manager
-> Double-click your network adapter
-> Power Management
-> Remove tick in "Allow the computer to turn off this device to save power".

This helped me on some networks, where I could see the network and have excellent signal strength, but it would not connect.

share|improve this answer

Could be someone nearby powering up there router. Work your way through the wireless channels and see if there's any improvement. Remove anything that uses a wireless signal from the area too

share|improve this answer
up vote 0 down vote accepted

This is an old question isn't it? Well half a year has past and I have a new router by now. Problem solved?

share|improve this answer

I had this problem on a Vista labtop with a Linksys router. After several months with no solutions, I tried Tomato. It fixed the problem, and I never looked back.

share|improve this answer

DD-WRT is an excellent solution. When Fonera was giving away free acess points, I grabbed two access points and went to work. I love the front and back end of the software.

One thing I would suggest taking into consideration is faulty hardware. Check to see if all other devices remain connected and ensure that the router itself does not constantly reboot.

Another thing to take into consideration would be if your ISP utilize DOCSIS. If that is the case, your router could be being forced to upgrade/downgrade its firmware and is stuck in a loop.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .