Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a lenovo ThinkPad running Fedora 14, and am unable to enable wireless. Fn+F5 doesn't switch on the LED indicator light, and adding a network via System->Network Connections->Wireless doesn't do anything (not that I expect it to with the wireless adapter evidently off).

I saw the following question: Fedora 14 wifi card wont enable

but it seems like I may have a different problem because lspci shows the following:

lspci | grep Realtek
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

How can I troubleshoot this problem? It seems like it ought to be straightforward to enable wireless network access on a thinkpad running Fedora.

share|improve this question
I had a similar issue with SuSE some time ago. Never got it resolved. Have an "I feel your pain" upvote. – Pops Feb 23 '11 at 23:19

I agree with the solution above. I have a Lenovo T510 and I was looking for these wireless drivers for the last few hours. My Wireless specs are: "Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller" If you are unsure type lspci and look for 'Network Controller' in the list that will appear.

I have Fedora 14 and even though I get Internet via wired connection out of the box, the wireless was not recognised. I found the above compressed file on the Internet. Here's a link: Drivers Download Site

Just note that it doesn't have a 'build' directory and it may fail when you first try to install. If so just run the following two commands and try again:

yum install kernel-headers kernel-devel
yum groupinstall "Development Tools"

Then try again installing the drivers. After you extract the compressed file go to its root directory:

cd /your/path/to/rtl8192se_linux_2.6.0019.1207.2010

and install the drivers. After a restart, the wireless should be up and running.

make install

I hope you find the above useful.

share|improve this answer
up vote 0 down vote accepted

I eventually solved this by installing a driver that was slightly different from my hardware, but it worked anyway. I downloaded rtl8192se_linux_2.6.0019.1207.2010.tar.gz and built and installed the drivers, and it seems to work fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.