Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing LibreOffice and then unistalling OpenOffice, all the files for the many office document types (odt, ods, doc, xls, rtf and a dozen more) are unassociated with any application. When I try to associate the file with an application the short way (right click > open > select the program from a list), none of the LibreOffice applications show up in the list. If I click the Browse button and pick the executable in the LibreOffice 3 folder, the program is not added to the list so that I can select it.

This leaves me to have to associate all the file types the long way (windows explorer > tools > folder options > file types etc.. )

Is there a way to "register" an application so that it is available for selecting from the "Open with" application list in Windows XP?

Thanks!

share|improve this question

9 Answers 9

See How to Add a Program to "Open With" in Vista and Windows 7 :

When you right click on a file and click Open With, a list of registered programs are displayed in the Open With window to choose from. This will show you how to register a program so that it will be added to the Open With list.

share|improve this answer
    
The methods described in that post either doesn't work for LibreOffice, or is not available in Windows XP. I am reluctant to install an untrusted program just to do this one job. I am sure one can configure windows without too much trouble. –  JannieT Feb 24 '11 at 12:50

The easiest way to create a file association is to drag a document (with the file extension you want to associate) onto the program you would like to open it with. The next time you click on the file with the right mouse button, the program will appear in the "open with" list.

Just to clarify the process of creating a file association:

First, find the file of the type you want to associate to a program.

Right click the icon and a menu will appear. Choose Open with… A window will open asking you to choose a program to open that file type.

Pick a program from the list.

If the program isn't on your list, choose Other to navigate to another file or program on your hard drive.

share|improve this answer
1  
Opening the document by dropping it on the program executable doesn't add the program to the open with list. And, as I explained, in my question, the standard method doesn't work for LibreOffice. I have no trouble associating extensions with other programs that are not in the list. –  JannieT Feb 24 '11 at 12:47
up vote 1 down vote accepted

This seems to be a LibreOffice specific thing. I reinstalled LibreOffice and voila! all the applications were available in the "Open with" list and it is now easy to associate file extensions. Thanks for everyone who offered general help. If I suspected an incomplete installation of LireOffice in the first place I would not have asked the question so generally. Maybe this case can help someone else who have this kind of trouble after installing LibreOffice before uninstalling OpenOffice.

share|improve this answer
    
It did help someone else, thanks. :) –  Ilari Kajaste Oct 24 '11 at 18:40

You could try a utility like Default Programs Editor to do this. Go in to 'File Type Settings', then 'Change Open With Programs'. Select the file type to change, then add/remove the applications you want

Default Programs Editor changing open with programs

share|improve this answer
    
This is part of what harrymc suggested. See my comments there. Thanks. –  JannieT Mar 2 '11 at 13:43

I had a very similar problem. It was possible to manually set file associations for Base, Draw, Math and Writer(Web), but NOT Calc, Impress or Writer. No matter what method you use (in Windows) those three do not appear in the list, even when you specifically select them. Just trying a re-install. Will let you know if that works!

share|improve this answer
1  
It did work. Involved a good old fashioned restart too. Disappointing, but I can live with it :) –  Rev Nev Apr 24 '11 at 12:52

Just modify the registry:

HKEY_CLASSES_ROOT\Applications\scalc.exe\shell\new\command

Open the default value, and change the OpenOffice path with LibreOffice.

share|improve this answer

In \Documents and Settings\Default User\SendTo add shortcut to the desired program. Use RightClick, choose "Send to" and the program from the list. (You may have to restart Windows to recognize the change).

Add same to other users / all users.

share|improve this answer

Worked for me (in WinXP)

  1. regedit
  2. search for the Key about VLC/VideoLAN inside the Key HKEY_CLASSES_ROOT\Applications\
  3. delete the Key about VLC inside HKEY_CLASSES_ROOT\Applications\
  4. close regedit
  5. try Open with... dialog like usual (browse for program, etc) them VLC media player will finally appear in the Open with dialog list
share|improve this answer

On my system previously had uninstalled open office then install LibreOffice and got same problem, used regedit to search for swriter.exe, found open office uninstall did not delete all its registry entries leaving HKEY_CLASSES_ROOT\Applications\swriter.exe\shell\open\command value as "C:\Program FilesOpenOffice\program\swriter.exe" replaced that with "C:\Program Files\LibreOffice 4\program\swriter.exe" and other LibreOffice exe's and file explorer open with browse works to associate "C:\Program Files\LibreOffice 4\program\swriter.exe" with documents

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.