Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a sound card that is able to sense what jacks are plugged in where. The problem is that it keeps detecting my speakers on and off (they come and go randomly).

Last time I had this problem I checked everything (cables, velds, etc), and finally found a change I could make to the registry to disable jack sensing. It worked fine for a couple of years until yesterday when I reinstalled Windows.

Its an Asus RoG Maximus Formula motherboard with a X-Fi soundcard (came bundled with the MB).
The ASUS drivers either bluescreen or say I don't have a valid card. They are also for SoundMax, which I suspect is not compatible with Creative X-Fi?

I've tried the fix described on http://windows7forums.com/windows-7-support/54848-windows-headphone-plug-sensing-broken.html without any luck.

Any idea how I can disable the auto sensing?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Found it.

  • Open registry Editor with elevated privileges
  • Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\GlobalSettings
  • Change the value EnableDynamicDevices to zero.
  • Restart your system.
share|improve this answer
    
Don't forget to mark this answer as accepted as soon as you can! –  AndrejaKo Feb 24 '11 at 19:43
    
+1. Very thanks. I didn't wanted to install propietary drivers - so your answer helped very much. –  0x69 May 5 '12 at 9:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.