Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am going to www.facebook.com, but the site that appears is totally different. This occurs on Chrome 6+, IE9, and FF 3+. What could be happening? Is this a security risk?

Facebook was working just fine, then all of a sudden this happened.

screencap of Facebook.com, but the site is completely different

Update: The same problem occurs on my netbook.

Update 2: When I go to http://69.63.189.11/, it works fine. So... DNS problem? How do I fix?

Update 3: Checked the hosts file:

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost

Looks like it hasn't been altered.

share|improve this question
15  
Did they change the UI AGAIN???? (jk) –  Brian Postow Feb 24 '11 at 21:15
    
Flush your local dns... ipconfig /flushdns...tech-faq.com/how-to-flush-dns.html –  Moab Feb 24 '11 at 21:24
2  
Reboot your router. Check your router settings, see what dns servers it is using. –  Moab Feb 24 '11 at 21:26
1  
try changing your DNS server and see if the problem is still there. I think google's DNS server is 8.8.8.8 and 8.8.4.4 (sad that I have them memorized). –  stoj Feb 25 '11 at 1:03
    
Check your Internet Explorer proxy settings. A lot of malware will set that to a proxy on your own system to redirect, modify, and intercept traffic. Firefox and Chrome by default will follow that setting. –  TuxRug Feb 25 '11 at 6:17

9 Answers 9

up vote 13 down vote accepted

Virus/Trojan/Worm or your DNS cache is hosed.

share|improve this answer
    
OP updated. Looks like there's a DNS problem. Does this exclude the possibility that this is a symptom of malware? (I'm guessing not.) –  Rosarch Feb 24 '11 at 21:18
8  
@Rorsarch - No, a dns issue definitely does not eliminate malware. Lots of malware will use dns poisoning to redirect you to their pages. –  Joel Coehoorn Feb 24 '11 at 21:37
    
you can try to remove all virus/ trojan and flash dns cache using this command: ipconfig /flushdns –  nXqd Feb 25 '11 at 2:08

My first instinct is that it's a DNS problem. What happens when you try the test at the top of this guide?

EDIT:
Hm, that's unfortunate. From the same guide (emphasis original):

If things were working correctly with your exact same network setup, and then mysteriously stopped working, it's possible that your ISP's DNS servers are having problems. Contact your ISP's tech support to report the problem and ask them to fix it!

The ISP explanation seems likely because it's happening across all browsers. This has happened to me a few times, and it's always been resolved after a few hours without me doing anything. Fortunately, the site that was down was never critical.

It also couldn't hurt to try flushing your local DNS cache. Since you mentioned IE9, I assume you're using Windows 7. Pop open a command prompt and enter

ipconfig /flushdns

(or just enter that directly into the search/run box in the Start menu).

share|improve this answer
    
Looks likely. OP updated after doing that test. –  Rosarch Feb 24 '11 at 21:17

Check your host file in

C:\windows\system32\drivers\etc\

I wonder if someone changed an entry in there, maybe playing a prank on you.

share|improve this answer
    
I don't think it has been changed. (OP updated.) –  Rosarch Feb 24 '11 at 21:19

You might have downloaded a trojan without your notice... There are some virus files which will never allow you to get access to some popular website like FB and other (Depends upon the trojan code) So, I guess browser re-installation do not fix it because virus file is installed in your system's hard disk.

When coming to your Netbook. You might have transferred any data from your PC to Netbook this results carrying for your virus...

Probably Anti Virus scan and Registry scan together results no use...

So, now just manually click CTRL+SHIFT+ESC to open Task Manager and check for the processes and end what all the programs you have doubt (Hope you know what program processes you should not touch) And then try if your terminate the correct process 100% your issue will be rectified.

Check now probably FB will open correctly...

After this, all processes will start again with a reboot. So, manually search for the process name and use "F3" to make search in your hard disk and delete that file or block the access for that file from your anti virus firewall.

Hope this helps you.... Revert me back if it works or not or if you need any further assistance...

share|improve this answer

Switch your DNS servers to Google Public DNS and see if the problem persists.

share|improve this answer

Just wanted to add since it does seem to be some kind of DNS corruption, you can use NSLookup to see what IP address your PC thinks "www.facebook.com" corresponds to.

To use go to "Start"->"Run" and type NSLookup. Then simply type "www.facebook.com" at the prompt. See if it differs from what others have listed for www.facebook.com:

> www.facebook.com
Server:  <my dns server>
Address:  <my dns ip address>

Non-authoritative answer:
Name:    www.facebook.com
Address:  69.63.181.12

Best of luck!

share|improve this answer

Some malware will try to hack your router using well-known default router passwords. I suggest you get into your router interface and change the DNS Servers as others have suggested. (I like OpenDNS rather than Google - 208.67.222.222 and 208.67.220.220). Then CHANGE your router password so it doesn't get hacked again.

Cheers, Rich

share|improve this answer

Solved this last month. I bet you are using a Linksys router? Update your router firmware and it goes away.

Please let me know if it works!

Good luck

share|improve this answer

Run your Command Prompt as administrator and copy and paste the following command:

ipconfig /flushdns

Then press 'Enter'

Works for me every time. Hope it works for you as wel!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.