Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a fairly clean Vista Home Premium SP1 install on my desktop. There aren't many applications installed. My Internet connection always seems to stop working after web surfing for a while - sometimes 5 minutes, sometimes half an hour. (It doesn't matter whether I'm in Internet Explorer, Firefox, or Opera.) Nothing restores the connection other than a reboot, which I have been doing at least once a day.

All other machines on my network are Windows XP, and they all work fine even when this Vista Internet connection stops working. Also, file shares to and from the Vista machine work okay even when I can't get out to the Internet.

Things I tried:

  • Pinged various websites
  • ipconfig /release /renew, etc....
  • Rebooted router (Belkin - Yeah, I know it's crappy)
  • Rebooted cable modem (TimeWarner)
  • Disabled AVG antivirus and ZoneAlarm firewall
  • Uninstalled AVG/ZoneAlarm
  • Did a spyware scan with several programs - CLEAN!

Also, I should point out that this machine has been working fine for the year or so that I've had it. These problems have started in the past month or so, although I can't remember anything I did that would have caused any issues. My System Restore points somehow got lost, so I can't do a System Restore.

How do I fix this problem?

Also, I tried using OpenDNS and am getting the same results if it makes a difference.

I am fairly knowledgeable with both Windows and networking, but this one's got me scratching my head!

share|improve this question

closed as off topic by Diago Jan 17 '10 at 14:04

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What sort of ping results did you get? Google by name? Google by IP? Router? Modem? Did renewing your IP give you a valid IP? –  Ciaran Aug 18 '09 at 21:04
    
Is this a wireless internet connection? –  Mark Aug 18 '09 at 21:05
    
This is not wireless connection. I can't ping anything but the local network and the machines on it. That sounds like a router problem, but why does it always start working again when I reboot the PC? –  SomeGuy Aug 21 '09 at 23:21
    
I should point out that when I do restart my PC, it sits there for a 1-5 before starting the restart process. Once in a while, I even have to hold down the power button to shut it down. (Core2Quad/3GIG Ram) –  SomeGuy Aug 21 '09 at 23:22
    
I'm having the exact same problem (and was about to post a question about it). SP2 doesn't fix the problem. –  Al E. Aug 26 '09 at 19:36

8 Answers 8

up vote 1 down vote accepted

From a command prompt run:

netsh winsock reset

That will reload the TCP/IP suite for Windows and can correct some issues.

If you are using a USB adapter, whether wireless or wired, go into Device Manager and turn off the ability for Windows to shut down the device to save power. You may have to do this on the root hub and controller that match your device.

share|improve this answer

Install Service Pack 2.

share|improve this answer
    
Yup. Vista SP2 gave me so many further network problems that I went right back to SP1! –  SomeGuy Aug 20 '09 at 20:44

I have the same problem with both Windows 7 and Vista. I have an Atheros wireless card in my cheap laptop. It works with Ubuntu and Windows XP. It leads me to believe that the driver support for these cards is really bad with Windows Vista (and hence Windows 7).

share|improve this answer
2  
If its affecting Win7 and Vista have you tried turning off IPv6? –  Ciaran Aug 18 '09 at 22:33
    
I had a similar problem with an Belkin card in my desktop that uses Atheros hardware/drivers running on Windows 7. I have since stopped using the wireless card and now use a wired connection instead. The card doesn't have any good drives for Windows 7 so that was my only option besides getting a newer wireless card that is "certified" to support Vista/7. –  Chris Pietschmann Aug 19 '09 at 8:20

If you using a USB device to connect, sometimes Windows Vista will randomly kill USB ports.

share|improve this answer
    
Nope, this is a onboard intel network device. –  SomeGuy Aug 20 '09 at 20:45

I had the same problem. Disabling my Trend Micro Internet Security seemed to do the trick. It was corrupted, so I suggest you checking for that if you have Trend Micro installed.

share|improve this answer

You may want to uninstall SP1. I've had a few issues with network adapters (especially Dell integrated wireless adapters) and SP1. If this is an issue you may need to update the driver previous to reinstalling SP1. This will be the case if the problem did not exist prior to the update.

share|improve this answer
    
It may help the problem, but you generally don't want to stop getting updates altogether. It'll be better to nail down the issue and get it fixed. –  Chris Pietschmann Aug 19 '09 at 8:22

Uninstall ZoneAlarm, don't just disable it. Uninstall it if you have it.

share|improve this answer

OK, I'm back again. Yes, it's basicly any useless program you're not using. I have a clean install, so I don't have too much. Anything that has to do with connecting to the Internet will mess up the connection. Most programs actually do. Try uninstall one at a time or two to see if it fixes the problem. I'm using Trend Micro.. you said yours was corrupt? Try reinstalling it again and see if that helps you. I only have this problem after 40 hours of use, but I still connect - I just have to press F5 a few times.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.