Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Buffalo wireless router and it appears to work fine, for the most part. However, printing out some debug information, I noticed that the Mode is reported as unknown/bug.

In the DD-WRT configuration, I have selected AP which should be Master. I was having a problem earlier with my ESSID being a bunch of weird characters. I re-entered it and restarted the router and now the ESSID is correct.

I tried re-entering the configuration for the router and it still is reported back as Unknown/bug via iwlist wlan0 scanning.

Any ideas?


share|improve this question
What model is the router? If it's a Broadcom SoC, you might just need to do a 30-30-30 "hard reset" to clear your nvram. – brianbaligad Feb 25 '11 at 3:30
It is the n-finiti: wzr-hp-ag300h – Walter White Feb 25 '11 at 12:54
I tried a hard-reset, I am still having the same problem. I believe that is why some devices do not see the router. – Walter White Feb 27 '11 at 3:03
up vote 1 down vote accepted

The answer is that the build 14998 has some issues with my particular device. There are several fixes:

  1. either upgrade to the latest firmware which is greater than 15672.
  2. do not run the power kernel on the n900.
  3. upgrade the power kernel to fix an issue with seeing dd-wrt routers.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.