Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is a related question here.
I can use Administrator, install extra software, whatever needs to be done.

My problem is:

  1. I can't block websites entirely. Like in AdBlock Plus, you add a rule like:


    You can't do that with hosts, you need one entry for every sub-domain, etc.

  2. This won't block, only redirects to localhost.

    Okay, it does the job, but it waits for the resources, so it takes time to recognize its not there.

Is there a way to do this?

Maybe some kind of app that makes the PC respond there is NO such thing, don't search / try?

share|improve this question
Addition: I have a legal susbcr to Avast IS but I don't use the firewall there. It's yet too primitive. Basically I want to have a blocker stuff. If you know a firewall like that, I'm willing to pay of course! – Shiki Feb 25 '11 at 10:24
(Can't be even called firewall. I don't want to block applications or edit rules.. just block domain, IP, website.) – Shiki Feb 25 '11 at 10:25
Good news, everyone! Avast 6 comes with the old url block. Yet it shows a HUGE picture instead of the blocked resource. Now that's quite.. annoying/useless. – Shiki Feb 25 '11 at 11:39
up vote 2 down vote accepted

Privoxy can do this, it allows you to customize it the way you want it to be...

share|improve this answer
Hmmm I've been using privoxy ..but... if I use a proxy.. won't it disable my pipelining in Firefox for example? – Shiki Feb 25 '11 at 17:41
@Shiki: Privoxy would handle each connection you create as another connection, and would open a new connection to the internet for each connection you make. So I don't think it would disable your pipelining. – Tom Wijsman Feb 25 '11 at 18:29

The reason your HOSTS entries are taking so long is because you are redirecting them to the localhost, but you (probably) have no web server running on the localhost to answer, so you have to wait for the browser time-out.

Perhaps turn on IIS to answer the localhost requests, or set the HOSTS to redirect them to a fast site like or alike instead of localhost.

share|improve this answer

You should redirect your entries in etc/hosts to something like

Or, you could install Proxomitron and add a header filter named:

URL: Kill domains

Specify the domains you want to kill in the URL Match: field to kill them. For example:


And just put

in the Replacement text: field.

share|improve this answer
But he doesn't want to do that for each sub domain. – Tom Wijsman Feb 25 '11 at 16:49
I understand. But at least the delays will be gone, and no pages are served, from a local web server or anywhere. Hacking etc/hosts is a cool trick that many use wrongly, so I think the tip is still useful. – TheNewbie Feb 25 '11 at 17:33
Well its already better than the method, thanks! – Shiki Feb 25 '11 at 17:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .