Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, when I am recording an action, when I try to align an object to the top left of the layer, it does not get recorded. Why is this happening? Even if I try moving the option with the keyboard arrow keys, it does record it at all.

I am using Adobe Photoshop 7.

share|improve this question
    
What "object" are you trying to move and align? – martineau Feb 25 '11 at 12:24
    
As in a square, rectangle, circle, pasted image from clipboard etc etc. – oshirowanen Feb 25 '11 at 16:07
up vote 0 down vote accepted

Can't remember if PS 7 had the feature, but try selecting all canvas (ctrl + a), then provided that the object is solid (even if has transparency) and the remaining background of the layer where it is, is transparent, and that you are actually on that layer (selected in layers dialog), then, go to top menu "Layer", then "Align layers to selection", then "Left Edges", then top menu "Layer" again, "Align layers to selection", then "top edges". That should do it.

share|improve this answer
    
I've been trying that, but when I click left edge, the object moves to the left, but no action gets recorded in the actions section except the bit where I clicked ctrl+a... – oshirowanen Feb 25 '11 at 16:08

Photoshop action doesn't record layer selection by clicks. If you're aligning to a specific layer, you have to make the layer selections by keyboard shortcuts within the layer palette. It helps if the two layers being aligned are on top of each other.

Shift + opt(alt) + [ or ]

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .