Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OK, I know this is the very basic thing that goes with Windows, but I am asking it here in search of answer.

I put my pendrive and it autoruns. This changed the show hidden files option off, I mean I am not able to see my hidden files as it is not applying the changes. What is the registry file that has modified?

I have scanned my computer using 4 antivirus programs. BitDefender found and deleted something in temperary folder. The rest didn't showed anything.

I have encountered this problem a few more times but this time I don't want to format it ;-)

share|improve this question
1  
Can you clarify how you're "un-hiding" files? Just so we know you're doing it right. Also, which operating system? Make of the USB drive? –  Ciaran Aug 18 '09 at 21:21

4 Answers 4

Your question is a little unclear, but I will do the best I can to answer it.

In most of the recent versions of Windows there are two "show hidden files" options.

The View tab for Folder Options for Windows 7

If you select "Show hidden files, folder and drives" you still will not see "protected operating system files" unless you also uncheck that checkbox. I think on XP you need to scroll down to see that one.

share|improve this answer
    
+1 did not know that! –  Ciaran Aug 18 '09 at 22:31
    
thanks a lot for your help –  crazygamer Aug 20 '09 at 21:01

Here is the registry key that you can check

User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ Advanced] Value Name: Hidden Data Type: REG_DWORD (DWORD Value) Value Data: (1 = show hidden, 2 = do not show)

share|improve this answer
    
oh thanks a lot but this one worked only once(i mean i showed hidden files and when i tried again by clicking do not show and than show hidden files it didnt worked) but i got the solution it was in the following registry key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\F‌​older\Hidden\SHOWALL i set "CheckedValue" value to 1 and now its working thanks for your support –  crazygamer Aug 20 '09 at 21:00

If Jim's advice still did not allow you to see the hidden files on your system, consider using another antivirus software to re-scan your system. I recommend using Trend Micro's Sysclean (instructions to use are here).

That usually happens when a modified autorun.inf file runs from infected USB drives. If the infection has been removed by the previous antivirus programs you ran, then what Jim said should already resolve your problem.

share|improve this answer

Its very famous Virus for Windows XP - Executed from USB Devices - autorun.inf file...

I've found a solution for that - overwriting the registry values to default from another windows XP by Export and Importing registry entries of location HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced

I've also kept the backup of it online Here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.