Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First off, this isn't the usual "physical" feedback of a speaker being too close to the mic. This mic is part of a headset so there's no way for the output and input to overlap and cause feedback. This mic has worked perfectly for me in the past, but I recently re-installed my OS and it hasn't worked since.

It seems as if my audio out is getting redirected to microphone in. If I open up and sound recording program while I have some audio being output, the output will get echoed back in through the microphone channel, although any actual microphone input is never picked up. I can blow or scream into the mic and there's no indication at all that Linux is picking it up.

I'm running ArchLinux with ALSA. I've gone into alsa mixer and played with just about every channel in every way I can think of, and none of the options seem to fix the problem.

How should I fix this? I use my mic pretty much constantly when I'm on the computer, being without it sucks.

share|improve this question
1  
Have you looked in alsamixer to check the different options for mic input? You should start there to see if there are different channels. Mess around with them - that's helped me in the past. – new123456 Feb 26 '11 at 5:11
    
Yeah, as far as I know I've messed with and changed every single option in alsamixer to no avail – DWilliams Feb 26 '11 at 19:53

this is a difficult question that i've solved in the past, although i am currently struggling with it. It involves trial and error while your ears are well protected. My problem is with a creative x-fi xtremegamer card, while my external usb edirol ua 1ex works no problem. The difference is either, first possibility: 1. in the setting regarding 'direct monitoring' of the external (e.g. mic port or line in) sound source which is producing an inappropriately autopatched system capture loop or, second possibility, 2. in the recording source settings, or possibly both. These could both be hardware settings problems, so you should say what sound carddddd you

share|improve this answer

Here's how I fix my microphone feedback problem. In a terminal i've enter alsamixer. First I've select my soundcard by pressing F6 (highlight the card you are using and press Enter) Then I've press F5 for All (will show you All input/ouput sliders) and i've found by shutting down one of the two "PCM" channel the echoing was going out, so I put it to zero.

share|improve this answer

I had a similar problem with mic feedback; I was able to hear myself talk which also caused white nose feedback. My answer may be a solution to your issue as well.

  1. Open term and run alsamixer

  2. Make sure you have the right sound card selected F6

  3. With F5 show all options

  4. Find Loopback column and disable it.

If that worked you should be able to hear the difference immediately.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .