Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to start an about 10 years old PC computer. But nothing is shown on the screen, and it beeps everytime I press a key on the keyboard. I can press Ctrl+Alt+Del to reboot the computer. The monitor is newer and seem to work with other computers.

I don't see anything from POST/BIOS at start or later. I have tried to change to another graphic card, but it didn't change anything.

What can I do to solve this problem?

Update: I have now tried with another computer (the one where the "another graphic card" came from) and I got the same problem. I doesn't show anything on the screen. Both these computers had a GeForce2 MX 400 graphic card. I tried with another computer screen it didn't work - it was showing "signal out of range".

So is the graphic card GeForce2 MX 400 too old for newer TFT-monitors?

I tried with a third computer so I know that the monitors are working, and both monitors work fine with that computer.

share|improve this question

2 Answers 2

The BIOS emits a pattern of beeps at initialisation time for diagnosing the system when there is nothing on the monitor. Listen out for these when you power up. Typical patters are:

Single short beep

The system has passed the BIOS power-on selft test.

Repeated long low-frequency beeps

There is a fault with the memory

One long three short

The video card failed to initialize

One thing I usually try is to reduce the possible causes to an absolute minimum. Remove all cards except the video from the computer and disconnect all hard drive and floppy drive cables. If the system then powers up right you can add the cards and drives back one at a time until it stops powering up right.

If it doesn't power up with just cpu, memory and video card connected then try taking out the memory and the video card and listening out for the memory failure POST beeps detailed above.

If it still doesn't work, take out the CPU and put it back in again making sure it's seated properly.

share|improve this answer
    
There is no beeps unless I press a key on the keyboard. –  Jonas Feb 26 '11 at 23:56
    
no beeps just means you have no internal speaker hooked up, just follow his advice about removing all but the core components. That is the sure way to find out what is wrong. –  MaQleod Feb 27 '11 at 6:06

Try reseating the power cables. Also, try clearing the BIOS using the jumpers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.