Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install ubuntu server using virtualbox 4.0.4 in a ubuntu 10.10 host OS. I have the iso image on my hard drive which I used to perform the install. I edited the settings and added this image at the storage section, selected it as a primary master, so I could boot from it and start the install process.

But now, each time I start the installation, at the very beginning or if I'm lucky, after I click on the install link at the welcome screen, the process hangs and all the computer is blocked. This happened 3 times already.

I even tried to perform the installation using an old CD I had with the 9.10 server version, thinking that the iso image might be the issue, but the problem still persists.

I dont know what could cause this problem. My computer is a dell laptop with AMD processor (I dont know if this is important). Any help is very appreciated.

share|improve this question
    
Do you mean your computer is completely blocked, not just virtual machine? If computer still somehow works (you could try to login with ssh, install openssh-server first), please attach output of dmesg. –  Olli Feb 27 '11 at 17:51
    
Yes, the computer freezes completely and I have to manually reboot. Sometimes, after I click on the link to start the installation, right after it changes the window size (first time it's a 16:9 size and then changes it to something like 4:3 I guess), the computer restarts itself :| –  misterjinx Feb 27 '11 at 17:56
    
Did you manage to resolve the issue? I'm facing the same problem right now with 11.10 server (guest) on 11.04 (host). –  bitmask Jan 12 '12 at 8:05
    
no, sorry, i haven't resolved the issue with virtualbox. i finally ended up using vmware, which worked flawless. –  misterjinx Jan 12 '12 at 8:25
    
Apparently, running a 32-bit guest works, while all 64-bit versions fail. Interestingly enough, the desktop installers inform me of a kernel panic, whereas the non-graphical versions simply show a black screen. –  bitmask Jan 12 '12 at 8:34
add comment

3 Answers

A few things to check which might be helpful (the VT option resolved a freezing problem on one machine for me in the not-so-distant-past):

  1. In your BIOS settings, make sure that the VT feature is enabled

  2. Check that your system BIOS is up to date (many people believe that the BIOS doesn't make any difference, but if it includes micro-updates to the CPU then it is important, and the BIOS updates sometimes include some very important ones)

  3. Disable the 2D and 3D graphics acceleration options in the VirtualBox settings for the Virtual Machine you're trying to install Ubuntu into

  4. If using 64-bit Ubuntu, try the 32-bit version instead (if it works, then this may provide a clue as to where to look next in addition to getting things working for now)

share|improve this answer
1  
Thanks for your answer. I'll try this and I'll come back with an answer :) –  misterjinx Feb 28 '11 at 7:58
2  
So, I checked for VT option - is enabled. I updated my BIOS. 2D/3D graphics acceleration were already disabled. I tried using a 32bit version and is still not working. After some seconds the computer still freezes and sometimes it restarts automatically. I'm thinking cu try with an older version of VirtualBox to see if this might be the cause :-<. Thanks anyway! –  misterjinx Feb 28 '11 at 18:57
1  
Just give it a shot using an older version of Virtualbox (3.2.8) and I'm having the same problem. I'm very disappointed :( –  misterjinx Feb 28 '11 at 19:16
    
Okay, so you've ruled out software (unless your Operating System is b0rked, but this is very uncommon with Linux/Unix environments due to the absence of a bloated Registry), so at this point I'd look at hardware problems as being the most likely culprit. (In my experience, I find that VirtualBox is a stable, reliable application that doesn't cause any of the dozens of computers I have it installed on to freeze or have any problems.) –  Randolf Richardson Aug 13 '11 at 22:10
    
Also look at overheating as a possible cause -- are all your fans working, and keeping the air flowing through your computer to keep the major components cool (hard drive, CPU, motherboard, etc.)? –  Randolf Richardson Aug 13 '11 at 22:12
add comment

I had a similar issue although my computer did not freeze, only the virtual one. After a few tries, I choose the expert install, and I finally got an error back:

This kernel requires an X86-64 CPU, but only detected an i686 CPU.

Unable to boot - please use a kernel appropriate for your CPU.

Although I do run Ubuntu 64bit as host.

share|improve this answer
add comment

The CD should be mounted as secondary master and not primary master. Your hard drive image should be primary master.

If virtualbox (and it's the same with most computers) can't find anything on the hard drive image it will attempt the CDROM image as the next option. Alternatively you can press (I think) F12 at startup to select the boot device.

share|improve this answer
    
When I try to install from the CD, the settings are like you say, but I still have the same problem. Sometimes, the computer restarts itself... –  misterjinx Feb 27 '11 at 17:04
    
What? There is no reason to have CD drive as secondary master. It's completely fine to have it as primary master, primary slave or secondary slave. If there is PATA in use. –  Olli Feb 27 '11 at 17:21
    
@Olli That's what I thought. Do you have any ideas on my issue ? –  misterjinx Feb 27 '11 at 17:33
    
@misterjinx: no, if I'll figure out something, I'll add separate answer (except if it's closely related to older answer). –  Olli Feb 27 '11 at 17:50
    
Thanks for your time! –  misterjinx Feb 27 '11 at 17:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.