Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox 3.5 doesn't load the CSS from only 1 site (www.makeuseof.com). Everything else works OK (graphics, etc.). I tried safemode but no luck. In other browsers same site works properly. What did I do wrong?

Edit (2009 Aug. 19): problem solved but I don't know how. Today I just discovered that site loads CSS and it works. I didn't make any changes (think so). Love Firefox :).

share|improve this question
    
Do you have AdBlock? If so, try disabling it and then reloading the page to see if it works. –  rightfold Dec 21 '09 at 14:05

5 Answers 5

Double check that you do not have "No Style" checked under Page Style

View > Page Style > Basic Page Style is what you want.

I would just like to add that all the styling is working for me on the site you pointed to in FF 3.5. I even checked the css links.

share|improve this answer
    
But if that is checked, won't the CSS from other sites be blocked as well? –  Isxek Aug 18 '09 at 23:20
    
You can set this option for every site separate. But anyway its not solution for me. –  chmurli Aug 18 '09 at 23:32
    
@Isxek - yes all the sites would be blocked @chmurli - I just wanted to throw this out there as an option and something to double check. –  Reece Aug 19 '09 at 15:53

Have you tried deleting any cookies from that site and clearing your cache? It might also be helpful to specify exactly which version you're using (i.e. 3.5.1, 3.5.2, etc.) and what OS you're using.

share|improve this answer
    
Cleaning cache doesn't work. I use win XP and FF 3.5.2 –  chmurli Aug 18 '09 at 22:52

(Said it a bunch of times elsewhere... but it's a new site right? :))

So, anytime you have a browser loading-specific problem, in Mozilla/Gecko-based browsers, the first thing you want to do is do a profile-isolation. The main reason? It is fast.

Create a new profile, try the site. If it works, then you know your profile had a problem.

(If you are not familiar with Profiles in Firefox see: http://support.mozilla.com/en-US/kb/Managing+profiles#Starting%5Fthe%5FProfile%5FManager)

--

In this particular case, if I had to guess the specific cause, I would say that your cache has messed up the file. You could try clearing the cache (from the preferences UI). If that fails, then quit, rename the cache directory in your profile, and try again.

share|improve this answer

I had similar problem. Firefox 3.5.6 and FireBug 1.4.5 suddenly stopped displaying default.css on some pages (not all, only some pages). The solution was simple. I completely cleared the cache (history of browsing, files, etc.) I restarted Firefox and all was working correctly. I hope that helps someone :)

share|improve this answer

Using Firefox 3.5.2 for Mac OS X, I can view your site's stylesheet file, and see the styled result.

As a test, try moving the CSS file so it's on the same level as your index - so it would be reading as http://www.makeuseof/styleblog.css.

And shouldn't this be on Stack Overflow?

share|improve this answer
    
Well, it's not my site so I cannot move css :). Using Opera I saved this page and than I open from local disk under FF - css loaded properly. I can't understand this, from some reasons FF blocks access to this particulary url. It's realy annoying. –  chmurli Aug 19 '09 at 0:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.