Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some files on Windows 7, and want to see what time it was that I read it this morning (February 27 morning), but when I right click on the file and choose Properties, I see

Accessed: Yesterday, Feb 26, 2011, 2:12:37PM

so I open the file to read the content again, and then open up the Properties again, and still the Accessed (date) is the same (Feb 26).

Even if I add a column to the folder for "Date Accessed", it still shows Feb 26. But today is Feb 27 and clearly I have "accessed" it... so how can I see the true last accessed date?

share|improve this question

The NtfsDisableLastAccessUpdate registry setting is enabled by default in Windows 7. This was a performance tweak that many people used in earlier OSes because it prevents a lot of excessive writes to the hard drive.

If you actually want the Last Access date updated the way it used to be, simply set the registry value to 0.

share|improve this answer
wow... i guess it should not show it when it is actually inaccurate... that can have a lot of confusion such as father talking to the son "I thought you said you looked at the doc this afternoon? I see the last access time being 5 days ago." Or, "I sentence you to 10 years in prison, as clearly you were lying, you said you were home reading that file, but we checked your computer and the last access date of that file was actually 2 months ago. You were lying in court." – 太極者無極而生 Feb 28 '11 at 6:25
Instead of going through the registry, an easier way would be to type this in an elevated command prompt: fsutil behavior set DisableLastAccess 0 – paradroid Jun 21 '11 at 19:34
"...excessive..." Exceeding what, one wonders. – ChrisJJ Aug 16 '14 at 1:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .