Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I work in a shared computing environment and the default setting is r-x for group and others; it's upto the users to change this. I can chmod and change the permissions for all the files. However any new files created all have the default permissions. Is there anyway to change that so that I don't have to chmod everytime or run chmod as a cronjob?

share|improve this question
add comment

migrated from stackoverflow.com Feb 28 '11 at 9:59

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 8 down vote accepted

The setting you're looking for is called the umask, and that's also the name of the command that changes it. To make a persistent change, add a umask command to your shell startup file -- probably named .profile or .bash_profile, in your home directory; if you don't seem to have any such file, post the output of these commands:

$ grep $LOGNAME /etc/passwd
$ (cd; ls -ld .??*)
share|improve this answer
    
For example: umask u=rwx,g=rwx,o= sets the default settings to 0770. –  tiago2014 Feb 28 '11 at 2:11
1  
thanks, I've set my umask correctly now. –  Anonymous Feb 28 '11 at 2:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.