Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Synergy setup between a Windows XP computer (Dual monitors) and a Linux computer (Dual Monitors). So it goes [XP1] [XP2] [L1] [L2]. The XP computer is my server (running Synergy+).

Synergy seems to work fine going from XP1 XP2 and L1 but I can't get to L2. My cursor bumps up against the right edge of L1 and shakes a little but won't go over to L2. However if I plug a mouse directly up to the Linux box I can go between L1 and L2 just fine.

share|improve this question
    
What distro of Linux is it you are using? –  Majenko Feb 28 '11 at 16:26
    
And how are you using two monitors? Multiple X sessions? Xinerama? –  new123456 Mar 1 '11 at 21:52
    
Multiple X sessions I suppose? Not Xinerama. Each display is a different resolution so I have them set as independent displays (ie can't drag a window from one to another). Could that be why? –  Ternary Mar 3 '11 at 15:52
    
That might be a stumbling block (you might Google using syngergy with multiple X sessions and see if you find any issues), which is all I can say without knowing Synergy. –  new123456 Mar 8 '11 at 12:13
    
Also, when posting a "reply" comment, it's common practice to start out with a "@" and then the person's username. That way, the reply notification system can notify whoever you're conversing with. –  new123456 Mar 8 '11 at 12:14

1 Answer 1

up vote 2 down vote accepted

I suspect [L1] and [L2] are separate X screens (:0.0 and :0.1) as opposed to separate X sessions (:0 and :1, running startx twice.) Synergy may only be configured to use [L1] so you may have to add a third entry in the config file for [L2], treating the two X11 screens as if they were separate PCs.

share|improve this answer
    
I finally got it working. You are correct they are different X screens and setting them up on the server side as different screens (L1 and L2 explicitly) and then using --display :0.0 and :0.1 on the client side got it working. Thanks! –  Ternary Mar 21 '11 at 15:33
    
@Malvineous - can you provide some details on how to do that? I'm having a similar problem and am not sure how to refer to multiple screens (with colons?) in my synergy.conf file. –  Chris Nov 5 at 19:11
    
@Chris: I believe your synergy.conf has two entries for the Linux machine, then when you launch the Synergy client you have to tell it which PC entry you are using and which X11 display to open. I guess the --display :0.0 and --display :0.1 parameters tell it which X11 display to use, and the --name option tells it which screen-name to use in the config file, since your single PC will have two different names. –  Malvineous Nov 6 at 1:03
    
@Malvineous - would you be able to help me on my other question (linked above)? I've tried using the display arg as above but synergy.conf chokes on the extra colons... –  Chris Nov 6 at 5:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.