Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We just bought a new router a few hours ago, and it does work. However, for some reason the speed is just ridiculously slow (compared to before, at least)! If I run a test on I get the following results:

Which are pretty good. But for some reason it's like the connection just "hangs" for a second when I navigate to a site through the browser (have tried different browsers). It's not on all sites, it kind of happens randomly. I think the browser cache might be speeding some sites up, because if I visit a site that I HAVEN'T visited before (since I cleared my cache), it takes like two seconds (if not more) to open the site. If I have visited it, it opens directly (it barely loads).

Not sure what to do, really. Any suggestions on what might speed it up? Any settings I can play with in the router settings?

The router is of the brand Belkin. I'm not sure about the model though, it says "Belkin, Play Max Wireless Router" on the box?

EDIT: Alright, it takes a lot more than two seconds. At least 3-4 depending on the site. Any suggestions?

share|improve this question
Once you have arrived at the site is it quick navigating around within that site, or is it slow on every page of that site? – Majenko Feb 28 '11 at 19:18
Can you tell us what OS are you using? Might be some random problem with your OS which you noticed when you changed your router. – apoorv020 Feb 28 '11 at 19:23
It navigates at normal speed once i've navigated to the site once. Really weird. @apoorv020: I'm running Windows 7 on all computers except one which i'm running Windows XP on, i have the same problem there. – qwerty Feb 28 '11 at 19:31
Are you connecting through wifi? Have you tried changing the wifi channel? – Jakub Konecki Feb 28 '11 at 21:18
The model will start with F7Dxxxx, then we can point you to the user guide, which may be helpful to change the DNS servers in the router firmware. If it is a 4301, then this is the – Moab Feb 28 '11 at 23:07

This issue may have absolutely nothing to do with the new router, just a matter of coincidence. If you can surf normal once a site loads, your issues could be one of many things. 2 things that come to mind is DNS resolving the names slowly. Try using a public DNS server such as Google. (I am running into class now, and will update this answer with instructions if your interested.)

The second thing I would look at is the browser add-ons. If you are in IE, and look at your browser add-ons, chances are 90% of them are not needed. Also, newer versions of IE also tell you how much time they are adding to browser loading. If you scroll to far right, you will see a number in brackets listed in seconds.

Go to this page, the "Wan DNS" screenshot is where you can manually set your DNS servers, you would uncheck the "Automatic from ISP" box, then punch in your DNS server ip addresses of choice. This is for a similar model and may not be exactly the same layout at yours, but should be close.

You can use Google public DNS servers

or Open DNS Servers and


enter image description here

share|improve this answer
Thanks for the edit. I got pretty swamped in class, and didnt get back on to complete my answer. – DaBaer Mar 1 '11 at 18:45

Maybe, is a MTU related problem? Check the MTU of your previous router and set it accordly in the new one.

share|improve this answer
MTU as in Maximum Transfer Unit? To begin with i can't find that setting in my new router's settings. I just found out there's a new firmware update for the router, i'll install the update tomorrow. I doubt that will fix it though... – qwerty Feb 28 '11 at 19:46
Yes, it's maximum transmission unit. – Jakub Konecki Feb 28 '11 at 21:19

Sounds like behavior I would expect from incorrect DNS server configuration. Response is faster than I would expect, but the router may use a fast failover for DNS. Check all the configured DNS servers.

You can test them individually using the nslookup command. Use each IP address as a third paramter to a lookup for a known site. Something like nslookup replacing with you DNS ip address. They should all return very quickly. If any does not replace the address.

You may want to use DNS servers from OpenDNS or Google.

share|improve this answer

Previously My home internet was fine with the 6Mbps service. Then the ISP upgrade to 10Mbps service and my home internet just crawl. It takes about 5 minute to get into any sight. It happened in both computers in the home networmk, both on Lan and Wifi. However I could solve this problem by Disabling the Firewall of my Router.

My router is TP-Link and the Router Fire-Wall selection is under the Advance Setting Tab. For the Linksis Routers, the Firewall selection is under the Utility Tab.

Some advice that the firewall feature triggers if you leave the router on for ever (24hrs) without switching off at night or at non usage hours. Routers hangs when they heat up for long usage. Some routers become OK after just switch off and cool down for an hour and not needing the disabling of router firewall.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .