Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just tried to install Windows 7 x64 SP1 on my desktop computer, but 10 minutes into the installation I get this error:

The filename, directory name or volume label syntax is incorrect.

ERROR_INVALID_NAME(0x8007007b)

My guess is that I have to reinstall the OS, but I'm wondering if I somehow can get a more detailed error message. I want to know what has got the wrong name/path? Anybody know?

share|improve this question
    
Which version of Windows? I think all versions of windows have a service pack 1 by now. –  Majenko Feb 28 '11 at 19:19
    
Oh, did I really forget? 7 x64. –  Eikern Feb 28 '11 at 19:34

4 Answers 4

up vote 1 down vote accepted

I ended up having to re-burn the installation media which helped me get past this error message.

share|improve this answer

Do you have RAID array or Storport setup as your c: . Often, these 7b errors occur when the driver for your non 101 ide controller is missing.

Is it perhaps an older motherboard with an nVidia MCP on it?

share|improve this answer
    
The computer is two years old, and pretty new. I haven't got any RAID arrays or anything, but I once tried to change the default %programfiles% to my D: disc (because I have a smaller 10000RPM system disc), I reverted it after a week. –  Eikern Feb 28 '11 at 20:29

Its probably happening when it is trying to create a Windows system restore point.

See if doing this cures the problem. your system restore Available disk list may look slightly different, remove the entry labeled (missing)

Resolution Click Start, type SystemPropertiesProtection.exe. The System Restore Properties window will open.

You may see two C: drives in the listing with the same Volume label (see figure below). Deselect the checkbox for the duplicate volume, and enable the checkbox for the correct drive (the one with Windows logo).

enter image description here

.

Source

.

Edit:

If this is not the case, turn off system restore, then turn it back on, try SP1 again.

If no Joy, disable your Security Software during the installation of SP1 by doing a clean boot, open msconfig:

Click the Startup Tab and uncheck everything

Click the Services tab. Click to select the Hide All Microsoft Services check box. Click Disable All, and then click OK. When you are prompted, click Restart, then install SP1

You can revert the msconfig changes after SP1 is installed successfully.

.

share|improve this answer
    
All of my drives (C:, D:, and E:) are only appearing once. –  Eikern Feb 28 '11 at 20:31
    
Check my edit above –  Moab Feb 28 '11 at 21:01
    
Doesn't seem to work unfortunately. –  Eikern Mar 8 '11 at 11:13
    
Disable Windows System Restore, the turn it back on and create a manual restore point, then try SP again. –  Moab Mar 8 '11 at 22:21

Try turning of AHCI and see if it allows you install after that. I've seen this issue a few times and it always related to the RAID controller, or enabling/disabling AHCI. Unless your running a SSD, using AHCI doesn't offer any tremendous benefits.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.