Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Microsoft SQL Server Management Studio (SSMS) corrupts the display results and query window in both versions 2005 and 2008 as shown in the screenshot. It seems like the window drawing / re-drawing display system repeats the scroll bars and does not draw / re-draw the content areas. This occurs on Windows 7 x64 on both a 2-monitor setup on a workstation and on a laptop.

A few add-ons such as Tabs Studio and a few screen capture utilities are in use, but the behavior persists even if these are disabled and/or unloaded and on reboot.

My question is if this is caused by something that is within my control and how the behavior may be fixed. In the meantime I am using Linqpad (wonderful) but we still need to use SSMS for a number of reasons and this is driving us nuts.

At least one other person has had this happen and has posted on MS's connect site, but it has not be resolved or address by MS as far as I can tell.

Microsoft Connect - SQL Server - Display corruption on SSMS at large resolutions on second screen

I have migrate from StackOverflow and tried to post the image, but as I don't have any rep over here I cannot, so here is a link to that posting which has the (important) screenshot:

Stack Overflow - Display corrupted with repeated scrollbar in SSMS MS SQL Server Management Studio

share|improve this question
add comment

1 Answer 1

I had this issue as well (SSMS 2008 R2, Win 7 64 bit, 3 screens, NVIDIA Quadro NVS 420).

The workaround that fixed the problem for me was was to change the 'Compatibility Settings' for Ssms.exe. Check the Setting: 'Disable display scaling on high DPI settings'.

enter image description here

Next time SSMS opened, no more annoying scrolling bugs.

share|improve this answer
2  
Personally I hit CTRL+R twice and that does the trick. –  ta.speot.is Aug 4 '11 at 11:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.