Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I mount a DMG image with

hdiutil -noautoopen

and try to suppress the finder window with any and all command line arguments to HDIUTIL it still open's a Finder window. There must be a way to prevent this... am I wrong?

share|improve this question

migrated from stackoverflow.com Mar 1 '11 at 15:21

This question came from our site for professional and enthusiast programmers.

    
Since I´ve just tried hdiutil attach -noautoopen /path/to/read-only.dmg and it worked fine, could you please specify what kind of .dmg you are trying to open (read-only or not, which format)? –  Asmus Mar 1 '11 at 16:32
    
I'm specifically testing with this one... airdownload.adobe.com/air/mac/download/latest/AdobeAIR.dmg –  ClintM Mar 1 '11 at 16:56
add comment

2 Answers

up vote 0 down vote accepted

By default the Finder will always auto open read only images. Try to pass -noautoopenro!

share|improve this answer
add comment

In Mountain Lion (10.8.3), none of the -noautoopen options worked. The -nobrowse option does, though:

hdiutil attach -nobrowse /path/to/file.dmg
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.