Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded Debian to Xorg 2.9.4 and installed nvidia-glx from experimental, version 260.19.21. This was somewhat of an uphill battle as the dependencies for the experimental nvidia-glx package are still somewhat broken. I got it to work without forcing the installation of any packages and without modifying the packages.

However, after the upgrade compiz performance has been abysmal. I am using the desktop wall plugin and switching viewports is really slow - takes a few seconds for each switch. In addition to this, every effect that compiz does, such as zoom animations for icons when launching applications, takes seconds. The viewport switching speed changes relative to the amount of windows on that virtual screen - empty screens switch almost at normal speed, single browser windows work almost decently, but just 4 rxvt terminals slows the switches down to a crawl.

My compiz configuration should be pretty basic. Xorg is likewise configured without anything special - the only "custom" configuration is forcing the driver name to be "nvidia". I've fiddled around with the nvidia-settings and compizconfig trying different VSync settings, but none of those helped.

My graphics card is: NVIDIA GPU NVS 3100M (GT218) at PCI:1:0:0 (GPU-0). This is laptop GPU that is from the Geforce GTX 200 series. Graphics card performance should naturally be no problem.


EDIT: In the end, nothing really worked, and I got really annoyed with the state of compiz and its support in Debian. Many nVidia driver revisions have passed and I am using Gnome 3 now, so I am accepting the best answers to this question even though the issue was not resolved.

share|improve this question
    
It seems this bounty is closing without a winner, and my problems still persist. –  Nakedible Mar 9 '11 at 8:24
    
See the update to my answer. –  Arrowmaster Mar 9 '11 at 9:44
    
If no solution is found, there still remains the possibility mentioned in my answer, that using experimental was the reason for the problem and maybe you should return to the stable configuration where you had a working and fast compiz. –  harrymc Mar 9 '11 at 9:54
    
Returning to a stable configuration means downgrading X from 2.9 to 2.7 - and everything dependent. It's not an easy path to take. –  Nakedible Mar 10 '11 at 11:35

2 Answers 2

up vote 2 down vote accepted

Are you also using the version of compiz from Debian experimental? The version of compiz in debian unstable (compiz 8.4) is over a year old while the one in experimental is rather new.

You can try running compiz with the --loose-binding option which is supposed to improve performance on nvidia cards.

Edit: I just saw a blog update from one of the Debian maintainers saying that the packages in experimental are currently being added and it might take a few days for them all to become available due to some complications. You should try testing them again as soon as they are all available.

share|improve this answer
    
The compiz from debian experimental is 0.9.2 git something, but unfortunately I couldn't find the libcompizconfig packages there for 0.9.2. Which made it uninstallable - so I haven't tried 0.9.2. If you can confirm somehow that 0.9.2 is installable from experimental, I might try it again. –  Nakedible Mar 5 '11 at 8:50
    
libcompizconfig0 from experimental (0.9.2) has not yet been compiled for amd64, only i386. Hence I can't test compiz 0.9.2 yet. –  Nakedible Mar 7 '11 at 8:59
    
libcompizconfig0 is present now, and I could upgrade everything to 0.9.2, but I couldn't get the gconf configuration backend to work so I didn't actually manage to get compiz running with any sane options. –  Nakedible Mar 10 '11 at 13:02

Many people found different solutions to similar problems.

Advice from this thread :

I had refresh problems until i did switched on the "Force synchronisation between X and GLX" - option on the workaround tab in the CompizConfig Settings Manager.

And from this thread :

Try running compiz with -sm-disable or/and --loose-binding. Disabling effects such as anti-aliasing in the terminals may help also.

And from this thread :

Option "UseEvents" "false"

EDIT

Have you gone through this document NvidiaGraphicsDrivers :

This document explains how to make use of NVIDIA video hardware on a Debian GNU/Linux system. The following section shortly describes the free drivers while the rest of the document covers the non-free but 3D-accelerated drivers.

If nothing works, it may be that using experimental was the problem, and that you should revert to the stable version, while of course reporting your experience to the developers.

share|improve this answer
    
"Force synchronization between X and GLX" option is for fixing window redraw problems and can only reduce performance instead of increase it. However, I tested it both ways. –  Nakedible Mar 5 '11 at 8:52
    
I have no anti-aliasing in my terminals and having used "--loose-binding" before, I am dubious that it will help this time. The use of "UseEvents" "false" also doesn't seem relevant according to the forum posts. But I will retry these options nevertheless a bit later. –  Nakedible Mar 5 '11 at 9:01
    
I have added above a link to Debian Nvidia drivers discussion, which also describes the free and non-free (but 3D-accelerated) drivers and their installation. –  harrymc Mar 5 '11 at 10:57
    
Flags --sm-disable or/and --loose-binding do not help. Neither does "UseEvents" "false". –  Nakedible Mar 7 '11 at 8:48
    
I've gone through the NvidiaGraphicsDrivers Debian page - mostly it contains very irrelevant info to this problem. I have an existing installation, I am using Debian packages and not running the binary packages from nVidia directly, etc. etc. The point is that I had a working and fast compiz before, which turned slow when upgrading X and nvidia-glx. OpenGL is still fast, so it's not about that. –  Nakedible Mar 7 '11 at 8:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.