Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed virtualenv + virtualenvwrapper on Linux Mint 10 LXDE. For convenience I've added the standard WORKON_HOME settings to my ~/.profile

export WORKON_HOME=$HOME/Envs
source /usr/local/bin/virtualenvwrapper.sh

Then I've noticed that workon does not work after login, which means the above commands were not run. If I source ~/.profile then it works. I'm really not sure what could cause .profile not being run? I've checked and I don't have .bash_profile or .bashrc.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

~/.profile is only sourced for interactive login shells. If you're starting a shell that's interactive but it's not a login shell, then ~/.bashrc is sourced.

share|improve this answer
    
See this answer and this one for more information. –  Dennis Williamson Mar 1 '11 at 20:07
    
Yeah, looks like LXTerminal does not work with ~/.profile. –  Beres Botond Mar 1 '11 at 20:33
    
@Beres Botond: You originally wrote that your setting didn't work when you logged in. Now you're saying that it doesn't work when you run LXTerminal. If you're launching an LXTerminal from your window manager, you're not logging in. Generally speaking, ~/.profile is the place to set environment variables so that they affect the environment of all programs run after login, but you have to log out entirely and back in for those settings to have that effect. –  garyjohn Mar 1 '11 at 20:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.