Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ctrl-C stopped working for me at the terminal when using zsh (on mac osx). I didn't notice the exact moment that it happend so I can't be sure what caused it.

I didd't update zsh in a while though. and didn't touch .zshrc (I have it at a repo http://github.com/astrails/dotzsh)

If I run bash, ^C works in it.

If I run any command, like cat, ^C will work to stop it too. but inside zsh it just doesn't do anything.

bindkey | grep \\^C

gives

"^B"-"^C" self-insert
  • zsh 4.3.10 (i386-apple-darwin10.4.3), installed though ports (zsh-devel @4.3.10_0+doc+examples+mp_completion+pcre)
  • mac os 10.6.6
share|improve this question
    
just tried /bin/zsh and ^C doesn't work in it too. hmmm. –  Vitaly Kushner Mar 1 '11 at 22:59
1  
Does it work without your .zshrc? (Try zsh --no-rcs.) –  Gilles Mar 1 '11 at 23:45
    
hmmmmm. it does. silly me. but I didn't change it in a while and there are at least 3 other people in the company using the same set of configs. –  Vitaly Kushner Mar 2 '11 at 15:38
add comment

2 Answers 2

up vote 1 down vote accepted

that was a bug in rvm (ruby version manager) that I did update lately

share|improve this answer
add comment

I had some funny business (mostly with CTRL-A just printing out "^A" instead of moving the cursor to home position of the command line), but I got rid of it by disabled the "vi-mode" plugin in .zshrc :)

share|improve this answer
    
why would I disable it if thats the mode I'm using? :) anyway, as you can see above the problem was with RVM –  Vitaly Kushner Mar 31 '11 at 12:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.