Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a problem with my 3G modem [Huawei E122]. It has internal storage and kernel assigns a device [/dev/sdX] to it. Because of that, every second time my machine will not boot - kernel panic - as my usb hdd gets assigned /dev/sdb instead of /dev/sda. I cannot use LABEL nor UUID in root= kernel parameter, as it is only available when using initrd, and I can't use it - I am using Debian on my router - mips architecture machine. I have to prevent this from happening, as my router has to start everyday and I have to be sure it works ok. I don't have physical access to restart it when something goes wrong. I don't use my modem internal storage, there's no SD card inserted. However kernel detects the reader and loads it. I can not prevent loading od usb drivers since my hdd is on USB as well.

I will appreciate any ideas.

share|improve this question
    
3g-modem.wetpaint.com/page/Huawei+AT-commands –  user81793 May 18 '11 at 12:37

1 Answer 1

up vote 0 down vote accepted

You need to disable the "ZeroCD" feature, which can be done with "usb_modeswitch", available for Debian.

See the man page for more details.

share|improve this answer
    
Yes, that's actually how I did it. –  Krystian May 19 '11 at 6:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.