Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is for a friend's network: He has a router that is a Cisco e 2000, and the modem is a Motorola 2210-02. The router comes back with unable to attain the IP from the PPPoE, he uses the PPP to authorize.

Any ideas chaps?

Additional information: It is configured with Windows Vista and Ubuntu 10.10

share|improve this question
1  
Isolate the problem by connecting directly to the Motorola ADSL router using an Ethernet cable and then run any diagnostics that the router has. Post the results. –  Hydaral Mar 2 '11 at 4:39

3 Answers 3

Make sure the name and password you are signing on to PPPoE with are correct. Call your ISP and make sure they are correct.

share|improve this answer

First step, as other have mentioned, is to isolate where the problem is.

First, we should see how are the router and modem set up to authenticate.

Unfortunately, I haven't worked with those particular devices, so I'm giving general information.

Normally modem can be set to authenticate to network itself or to work using RFC2684 bridging.

Both ways have their good and bad sides.

When modem is set to connect to the network itself using PPPoE bridging, for example, the whole part related to obtaining WAN IP is done on the modem. This way, you can focus at one device at a time. Some of the common problems I've seen in modem settings are user name and password and VPI and VCI settings. Make sure that they are correct. Also check protocol and multiplexing method. They should be set to what his ISP recommends.

Don't forget to check for the stupid, obvious things too! Make sure that the telephone cable is operational and that the modem is connected to the right side of the splitter (some call it microfilter). Check the lights output on the modem. If my sources are right, there should be 4 LEDs on the modem. One for power and one for Ethernet. Two other are more interesting.

There should be DSL synchronization LED. It can be red or green. If it's green, you have DSL synchronization and that means that physically line should be operational. If it's solid red or flashing red, that means that there could be problems between modem and DSLAM. Check all cables to make sure that they are correctly connected. If everything works fine, I'm afraid that it's time to call ISP's technical support and have them solve the problem, because there's a chance that it could be in telecommunications infrastructure and therefore outside of your reach.

There should also be Internet LED. If it's red, connection failed, if it's green, modem has connection, if it's flashing green, modem's attempting to make PPP connection and if it's off, then modem is set not to make PPP connection. If the Internet LED is off, try setting modem to make connection directly and make sure that you have correct settings before changing it back to RFC2684 mode.

In the end, there's also the reset button. It sometimes helps when you've tried everything and nothing helps.

In case the modem is very buggy, then reflashing firmware might help. On the other hand, it could also make the modem inaccessible, so be sure what you're doing before trying that option.

Now to turn to the router.

If the modem is set to directly connect to the ISP, then you should probably set router to get its address from DHCP. Also, it's considered a good idea to have modem on a different subnet from router in that case. This way, you'll avoid any connection issues with the router since the router isn't making any connection. I've seen networking experts frown at such a setup and call it very strange, but it's been working for me for 5 years now without any problems.

The other option is to have modem in RFC2684 mode. In that case, router should make the PPP connections. Again, there isn't much to be done. I couldn't find manual for E2000 (is that maybe Linksys E2000?), so I can't give any specific advice, but check your username and password and see if you need to enter service name.

share|improve this answer

is the modem doing the PPPoE authentication, or the router? If your modem already does it, then the router should just be set to obtain a dynamic IP from the modem. If the router is trying to authenticate and the modem is already authenticated, then the router will be trying to pull PPOE info from the modem, which of course will not work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.