Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My laptop cannot connect to my network all of a sudden except in safe mode. When it boots, it will show the networks available in the tray popup, but if I click connect on any, it says "Unable to connect" and the troubleshooter is useless. Shortly thereafter all the networks disappear.

I have tried removing IPv6 support as I have seen that cause problems. No joy. I've also tried removing the wireless network adapter in Device Manager and reinstalling it, also no joy. I've also tried attaching a USB wireless adapter, and it has the same problem.

If I boot in safe mode, then it has no problems at all.

Three other devices in the house connect fine, so I am pretty sure it is nothing to do with the router.

Any ideas what to check next?

I am running Win7 Ultimate on a 2GHz Quadcore with 8GB RAM with a Broadcom 802.11n wireless card.

EDIT: RE wired connections: What is very weird is that if i plug in a wired connection, then not only does it connect via the wired connection, but the wireless also starts working perfectly. And a soon as I unplug the wire, then the wireless stops working again! So it seems the wireless is right now working only in safe-mode, or when a wired connection is also plugged in.

share|improve this question
    
Does it work if you try a wired connection? –  Craig H Mar 2 '11 at 4:05
    
please see my edit –  eidylon Mar 2 '11 at 4:44
    
Hmmm... now it just automagically fixed itself. I REALLY dislike problems that just "fix themselves" out of the blue! I tried assigning my laptop a static IP address, ... maybe that will prevent the problem in the future? Not knowing what it was, I can't be sure. –  eidylon Mar 2 '11 at 5:19
    
And I should note, the static IP i've assigned it, is router based, not NIC based. As I do still need DHCP for connecting at work. –  eidylon Mar 2 '11 at 15:46
    
Well, this wound up being the last straw of weird behaviours going on, and I just rebuilt the system. That fixed it. B) –  eidylon Apr 3 '11 at 4:26
add comment

1 Answer 1

I've seen weird stuff like this before too. The solution has usually been a combination of:

  1. Resetting the WinSock stuff. Microsoft has traditionally had a moving target for these solutions in their KnowledgeBase, but searching with the keywords "winsock" and "reset" should get you on track to the right document which hopefully has direct links to download the WinSock reset tools -- http://support.microsoft.com/ is down right now, but hopefully they'll have it back up again soon for you.

  2. Getting all the Windows updates (including manually selecting the ones that aren't high-priority/important updates). Fortunately you do have a way of getting connected, so do this and go through all the reboots, and hopefully you'll be fine. Also check specifically on the vendor's web site for the BroadCom NIC updates if there are none included in the Windows updates.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.