Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a rotatable display which I tip up so that I can fit more code on the screen.

However any text on the screen looks just the slightest bit less sharp on the rotated display. Can anyone tell me why this is, or better yet, how to 'fix' it?

share|improve this question
1  
You may want to try rotating your head instead of the display to verify it's not a hardware issue. It could conceivably be the difference between the horizontal/vertical viewing angles. – Chris Nava Mar 2 '11 at 18:39
up vote 5 down vote accepted

That's probably to do with the ClearType settings.

ClearType uses subpixel antialiasing to smooth the edges of fonts. When you rotate the display the groups of red green and blue pixels will be in a different pattern (rotated through 90 degrees) but the operating system probably doesn't know about that.

http://en.wikipedia.org/wiki/Subpixel_rendering tells you all about subpixel antialiasing

share|improve this answer
    
This answer is probably correct. Although Windows might recognize that the physical display orientation is rotated, and switch the Anti-Alias method of font smoothing, rather than ClearType. – Ian Boyd Mar 2 '11 at 18:11
    
+1. Try recalibrating ClearType. – Shinrai Mar 2 '11 at 18:19
    
That makes sense. I guess windows didn't realise that my pixels are noew sideways. – Hannesh Mar 7 '11 at 18:30
    
Recalibrating will not help because ClearType does not support vertically stacked subpixels. – usr Dec 29 '11 at 21:47

This is probably caused by ClearType.

You may either :

  1. Turn off ClearType
  2. Manually adjust ClearType mode in Control Panel->Appearance and Personalization->Display, in the sidebar use 'Adjust ClearType Text'
  3. Use a product such as the ClearType Rotator to do that automatically :

ClearType Rotator responds to changes in screen rotation by resetting the ClearType parameters to match the current screen settings.

share|improve this answer

One thing that could be a problem here could be due to the fact that the way due to how TFT monitors are made gives them a very limited range of viewing angles, typically they are optimized for viewing horizontally and look distorted when viewed from above or below.

From this Wikipedia article on TFT LCD monitors manufacture:

TN displays suffer from limited viewing angles, especially in the vertical direction. Colors will shift when viewed off-perpendicular. In the vertical direction, colors will shift so much that they will invert past a certain angle.

The "less sharp" impression could be due to Cleartype as others have mentioned, but could also be due to your monitor having a vertical viewing angle that is very poor. This vertical viewing angle would become a horizontal viewing angle when the TFT is rotated. What this would mean is that your eyes would be seeing two different sets of colours and your mind is blurring them as it merges them together.

I would expect this to have gotten better in the last few years as manufacturing processes have improved.

share|improve this answer

I was having the same issue, and can confirm it had nothing to do with ClearType which I've played around with, tried disabling it altogether etc.

The solution: After changing the orientation to Portrait and rotating the monitor, and I discovered it by accident, all I did was turn off my monitor and turned it back on again. It then performed some kind of "auto adjustment" and immediately solved the problem. Display is once again clear and sharp just like in Landscape mode.

Some monitors may not do this on auto, so you may have to look for an auto-adjustment or auto-calibration setting of some kind in the monitor's menu.

Have a dual monitor setup, one horizontal and one vertical (which had this problem, it's a DELL 2209WA).

Hope this helps someone out there, good luck! :)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .