Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having the following problem: When redrawing text in 32-bit Windows 7 using the Classic Theme there's a very noticeable flicker. For instance, the 'length' meter in Notepad++, or the bit rate count in Foobar (for VBR files), and any other application that rewrites text in-place. It is extremely distracting as the whole message box containing the text flickers at the same rate I type.

Here is a small video (80 KB) of the issue. (recorded with my cell phone, excuse the poor quality). In case you can't see it because of the poor resolution, here's a still image of what you're looking at:

enter image description here

This did not happen on Windows XP and it doesn't happen in Seven if I use Aero, but this is not a solution as I want to use the classic NT theme. It does seem to happen on a Virtual Box VM running Windows 7 (without drivers but VirtualBox Guest Additions), but it DOES not seem to happen on a VM running Fedora 14.

System specs;

  • Athlon 64 X2 4600+
  • Gigabyte GA-MA78G-DS3H (Rev 1.0)
  • 4 GB DDR2 PC6400
  • Sapphire ATi HD4670 512MB DDR3 (750/1000Mhz)
  • OCZ Agility 2 60GB (Drive running OS and other binaries)
  • Western Digital Caviar Black 1TB
  • Two Dell 2007WFP 1680x1050@60Hz (happens on both)

On the Performance Option tab, Use visual styles is disabled.

What I've tried -- unsuccessfully -- so far;

  • Changing fonts
  • Updating video driver to latest version (January 2011)
  • Rolling back video driver to the version working in XP (October 2010)
  • Changing resolution / color depth (the Reverting In (x) seconds flickers a lot!)
  • Enabling / disabling ATi Overdrive
  • Underclocking video memory to 800 MHz (after a suggestion posted on Tom's Hardware)
share|improve this question
    
Have you tried disabling the Themes service? –  nyuszika7h Mar 2 '11 at 19:51
    
I disabled the Themes service. And, the flickering still exists. Thanks! –  Snc Mar 2 '11 at 20:08
add comment

2 Answers

I haven't seen this happen before (I typically use the Classic theme when my eyes need rest), however, I would suggest playing around with the power management settings and see if that has a positive effect.

share|improve this answer
    
Just tried it. Played around with the default profiles and created new ones both performance oriented and power saving oriented. It didn't seem to have any effect on the flickering. –  Snc Mar 2 '11 at 19:52
add comment

Have you tried playing around with the ClearType settings? Go to Control Panel and search for ClearType, and click on "Adjust ClearType text". That may help reduce the flickering.

enter image description here

share|improve this answer
    
ClearType is enabled (I can't read the screen without subpixel hinting). I tried disabling it but the flickering was still there. Thank you for the input. –  Snc Mar 2 '11 at 20:07
    
Did you try tweaking the settings? –  Juliana Peña Mar 2 '11 at 20:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.