Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Until recently my browsers started to ignore my hosts file. I have Windows 7 operating system installed.

I have tried:

  • Clearing browser cache
  • Issued "ipconfig /flushdns" from the command line
  • Issued "ping" from the command line (response was "Reply from bytes=32 time=1ms TTL=128")
  • Restarting unit
  • Backing up original hosts file and making a new one
  • Checking lmhosts.sam (everything is commented out)
  • Connecting directly to modem using cable
  • Checked \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DataBasePath
  • Tried it on another laptop with exactly the specs as I have

Then I tried

  • Changing entry to "" (ping ok, browser ok)
  • Changing entry to "" (ping ok, browser ok but only for a sec)
  • Issued "ipconfig /flushdns" from the command line (ping ok, browser not ok)
  • Changing entry to "" (ping ok, browser ok)
  • Changing entry to "" (ping ok, browser not ok)
  • Issued "ipconfig /flushdns" from the command line (ping ok, browser not ok)

Any idea why it worked for a moment? Or better yet anything I havent tried or some error I may have overlooked?

share|improve this question

migrated from Mar 2 '11 at 22:38

This question came from our site for system and network administrators.

Sounds like the connection is being proxied. Go to Control Panel->Internet Options->Connections and then click on the "Lan Settings" button at the bottom. Make sure the "use proxy server" button isn't checked.

Lot of time that will only affect the browser, which is why you're getting different results from pinging and visiting the site.

This can be a sign that you've gotten a virus. I'd try doing a full scan.

share|improve this answer
It is set to "Automatically detect settings", also tried doing a full scan using AVG couldn't find anything. – madkris Mar 2 '11 at 15:44
Uncheck "Automatically detect settings", it just looks in special default places for proxy setting information. If you don't need a proxy, it's a good idea to uncheck everything in the LAN settings window. – Bavi_H Mar 3 '11 at 3:37
Done. Still nothing. – madkris24 Mar 3 '11 at 9:28

If it pings correctly then hosts is working. This is a browser issue. I know Chrome does its own DNS prefetching and there's always the issue of you being directed through a proxy you don't know about. Is it your network? If not discuss with your network admins.

Also, it can be AV or some security setting. Hosts is often compromised by malware for phishing attacks.

share|improve this answer
Tried it on Firefox, Chrome and IE. Im sorry what does AV stand for? – madkris Mar 2 '11 at 16:16
So after doing a full scan with AVG AV, I downloaded AdAware, Spybot S&D and did a full system scan on each. All that was detected were some browser cookies. However I have noticed twice now that whenever my unit turns back on, one of my AVG AV components, the Identity Protection is disabled and im quite sure I did not do it. Also Id just like to ask whether it is possible to fix this problem if I reformat my unit and delete the backup of the previous windows 7? – madkris24 Mar 3 '11 at 9:31

I had this problem and it was caused by an Apache web server running locally in my computer. After I stopped it, the hosts files started to work as it should.

share|improve this answer

You can try to add www

This could be the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.