Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently had a laptop sent back to supplier for fixing a mainboard fault.

I got it back today and every time it boots up I am faced with:

"Setup is preparing windows for first time use"

Then once it gets to the desktop I get the sysprep dialog come up asking if I want OOBC or Audit actions. I can close it, but it just keeps coming back, and I cannot find any startup or boot actions, even downloaded autoruns, and that cannot find anything to do with it.

Ideally I do not want to format/fdisk as I have just spent hours installing everything on the laptop and I have my primary C:/ which has all windows and at worst case I can get rid of that, but I have a secondary partition D:/ which has a lot of stuff I cant lose as its work related and important.

Also to make matters more difficult I do not have a windows 7 disk, it was just pre-installed and they dont provide a disk.

Any help would be great!

share|improve this question
up vote 1 down vote accepted

I'm not sure how your computer ended up in this state or why it isn't leaving it, but you can try manually telling Windows that it's done with the sysprep process.

According to the TechNet article on the Windows installation process, the Windows Setup State is determined by the following registry key:

VALUE: StateName

And in the following file:

SECTION: [State]
VALUE: StateName

See what state your machine is currently set to in those two places. When installation is complete, as you wish it to be, the states should both be set to IMAGE_STATE_COMPLETE. If it is not, change it to that, reboot, and see if that helps.

share|improve this answer
Tried the above, and then reset but still happens. Each time it boots it resets the values back to: IMAGE_STATE_SPECIALIZE_RESEAL_TO_AUDIT, I have tried letting the sysprep do its thing but it just fires an error – Grofit Mar 3 '11 at 7:12
What error message does it display? What options are you given in the sysprep window? Have you tried putting it into OOBE mode? OOBE should run the default out-of-box experience, then things should work like a normal Windows install. – nhinkle Mar 3 '11 at 22:10
Given you the answer, I ended up just formatting my C:/ and just re-installing windows 7 off a friends disc. No matter what i tried sysprep remained, and even when I tried to let it carry out its OOB experience it just gave a fatal error and closed. – Grofit Mar 7 '11 at 11:26

Go to C:\Windows\System32\oobe, double click Msoobe.

Fill out the details and restart your PC.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .