Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Which 64-bit desktop Linux (GUI) distribution can I run on an Intel processor, especially in VirtualBox on Mac OS X? Ubuntu 32-bit works well. Ubuntu 64-bit is for amd64 only, I think.

  1. I know Mac OS X is 64-bit Linux. This is not what I'm asking about.
  2. It would be lovely if you could recommend a small install, or one that has a live cd version.

Update: I tried downloading the ubuntu-10.10-desktop-amd64.iso package and this is what I get:

enter image description here

Update 2: As far as I can tell I do have a 64-bit processor.

enter image description here

share|improve this question
    
Mac OS X is not Linux. It's Unix-based. –  oKtosiTe Mar 4 '11 at 19:57
    
Check MacTracker to see if your Mac has a 64 bit CPU. –  Daniel Beck Mar 4 '11 at 20:17
    
@DB - good thought, but I have the latest MBP with an i7 processor. I don't think the Mac is the problem. –  cwd Mar 5 '11 at 19:32
add comment

1 Answer

up vote 4 down vote accepted

Short answer: Ubuntu-64 will work.

Longer answer: "AMD64" applies to both AMD and Intel. (Intel tried an earlier 64-bit processor named Itanium, but it didn't catch on, so they adopted AMD's approach.)

Unix is a common ancestor of both Mac OS X and Linux. Mac OS X is not Linux -- they are cousins.

EDIT: Apparently you have one of the early Intel Macs, which had "Core Solo" and "Core Duo" -- not "Core 2 Solo" and "Core 2 Duo" -- processors. These are 32-bit processors. VirtualBox does allow 64-bit guests on hosts running a 32-bit OS, but still requires a 64-bit processor (with hardware virtualization support). So the short answer becomes: none.

This also means this Mac cannot run OS X Lion (a requirement of the current beta which seems likely to persist to release). To confuse things further, after "Core 2", Intel dropped the "2" and used "i"-something:

  1. Core Solo
  2. Core Duo
  3. Core 2 Solo
  4. Core 2 Duo
  5. Core i3
  6. Core i5
  7. Core i7

These are all "Intel Core". You have one of the first two. The processor is listed in About This Mac under the Apple menu.

EDIT TWO: Perhaps VirtualBox's CPU detection code incorrectly identifies the Sandy Bridge (2nd generation) i7. Also, the new MacBook Pros boot into a 64-bit kernel -- the older ones booted into a 32-bit kernel (even though they had 64-bit CPUs, and either way allows 64-bit apps). This caused other problems with VirtualBox 4.0.x which seem to be worked around by booting into the 32-bit kernel. You might try that.

share|improve this answer
    
I don't think it will work... I included a screenshot above. –  cwd Mar 4 '11 at 15:11
    
@cwd: probably you don't have 64 bit processor. You can check whether it supports 64 bit or not here - check if your processor has "+" in EM64T column. If yes, than maybe you are working on 32 bit OS and it can't boot 64 bit (I'm not sure about it). –  klew Mar 4 '11 at 15:34
    
@klew - I'm running one of the latest MBP's. System stats (above) show it has a 64 bit processor. OS is Snow Leopard 64 bit. Not sure why it won't work. I think I downloaded the correct, latest, 64 bit version of ubuntu. –  cwd Mar 5 '11 at 20:20
    
thanks for the update. i'll try booting into 32 bit kernel mode. this whole thing is odd, though. hopefully virtualbox will fix support on a future release :) –  cwd Mar 9 '11 at 18:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.