Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Core 2 Duo E7400 2.80GHz processor on my Intel D945gcnl motherboard. From CPU-Z, I know that my processor speed is 1596MHz with X6 multiplier and 266MHz Bus Speed on each core.

Why is my processor being operated at 1596 MHz rather than 2.80GHz?

From my side I've tried to disable SpeedStep from my bios by setting EIST to 'Disable' and also tried to change Power Option to 'High Performance' in Windows 7. And also done like suggested in this question: Processor not running at max speed

However it gains me nothing.

I've also tried to run a few massive applications together to check whether it was increasing at that time or not, but it remains the same.

  • Should I have to increase my multiplier or overclock to gain that lost speed?
  • Should I have to check my power supply for any problem? or anything else?

This is a desktop computer so there won't be any problems caused by a battery.

Here's my CPU-Z Screenshot:

enter image description here

share|improve this question
Has it always been like this? - you don't say. If it has suddenly behaved like this think of what might have changed it. Check the fan and heaksink, fitted correctly, wires connected to motherboard. It could be that the CPU thinks that it is overheating so reduces its speed. Is CPU-Z compatible with this motherboard-cpu combo, so as to be able to read the data? Have you tried another tool to compare? Power supply could be an issue, you may need one that could deliver more power. – therobyouknow Mar 3 '11 at 16:27
@Rob: Yeah,it has been always like this but I'd not knew of the low speed of my cpu than now. It was the first time I use CPU-Z and find this result. I've checked my hardware and found no problem with that. CPU-Z is totally compatible with this combo, I think. Do u tell me some name of CPU-Z like softwares that I may use to confirm my problem? – Soham Mar 3 '11 at 17:08

2 Answers 2

up vote 4 down vote accepted

According Intel's processor/motherboard compatibility tool that motherboard is not compatible with that CPU ("This combination is not compatible.").

You're lucky it's running at all. :)

My guess would be that that motherboard just doesn't support a 333MHz bus speed with an 8.5 multiplier, which is what would get you that 2.8GHz.

Instead (as you've seen) it's defaulted to 266MHz at 6x, which equals 1596MHz

share|improve this answer
1 are the saviour. – Soham Mar 3 '11 at 17:12
@Soham - I'd feel like more of a saviour if I could have said "Yeah, click XYZ, turn ABC, and poof it's fixed!". But the thanks is always appreciated. ;) – Ƭᴇcʜιᴇ007 Mar 3 '11 at 17:19

Check your driver manager as well your motherboard. Could need an update. My computer was doing the same thing, all good now, just check through your device manager and check even if it has no warnings next to it might still need an update.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.