Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Synergy Server on my laptop, and the Client side of things on my Virtual Desktop Session, both running a Win XP environment. I am able to connect no problem. When I move mouse to client machine, I can click on items and activate them, but I do not see my Mouse Cursor from the server. I can use keyboard shortcuts, but its a real pain trying to operate 2nd machine, with no mouse pointer.

Any ideas?

As a clarification, I have installed the Synergy Release as of Feb 20th (newest install) and when I stated that I installed the client on one and server on other, I was making incorrect generalizations. I installed same installer on both, just wanted to clarify which I was using as server, and which as client.

share|improve this question
    
please delete your comment and add it as an update to your question; you can edit your question as many times as you like... – studiohack Mar 3 '11 at 16:02
    
What do you mean by "virtual desktop session"? Is it a Citrix or RDP session being displayed on a different computer than your laptop? – rakslice Aug 1 '11 at 3:57
    
or is it a VMware/VirtualPC/VirtualBox desktop? Sounds fishy when you say Virtual Desktop Session. Dont get why you would need synergy in either case or Citrix's for that matter. – Marlon Aug 23 '11 at 4:02
    
Have you tried reinstalling Synergy? Have you tried an older version? Also, you should try this search query (synergy ~mouse ~hidden ~problem) on Google, it will search for different kinds of similar queries so you get the most accurate results... – Tom Wijsman Aug 25 '11 at 23:08
    
you may try newer - beta versions – mmatloka Sep 10 '11 at 22:06
up vote 1 down vote accepted

Not exactly solution to your Synergy issue but Microsoft have released similar software and I can say that it's equal if not better than the one you're using now.

So if you cannot find viable solution give it a try.

share|improve this answer

Different reports reveals possible (and working) fixes:

  • Remove an application called SecureCRT, check for other conflicting software.

  • Run the Synergy application in an administrator context.

  • Reinstall Synergy.

  • Get a different version, which might no longer include the bug.

share|improve this answer

Synergy a little bit buggy, I use it only if I must control different OSes (linux with windows) but if they are windows computers, I use Input director, its free and easier to set up

share|improve this answer

I had this problem.

Turned out connecting a mouse to my client machine resolved it. My guess is X isn't rendering a cursor on machines without a hardware pointing device. I bet it has to do with handling touchscreens without curors.

I'm just leaving my house hooked-up. But I bet there's an X config parameter for this too.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .