Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have read a lot of tutorials, but I am still having problems.

What I tried:

I downloaded mysql-5.5.9-winx64. All that I read says that I can run Setup.exe, but there is no such file in the download. The other option I know there is, is including \mysql-5.5.9-winx64\bin in the PATH variable and then trying to execute the mysql command. When I do that, the error I get is:

ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)

I then downloaded mysql-5.5.9-winx64.msi, which is easier to install, but once I followed the instructions and it was installed, I got the same error executing the mysql command. How can I use MySQL?

EDIT: I've now removed everything I installed, and I want to start from scratch.

share|improve this question
    
Cross posted on SF - serverfault.com/questions/242925/… –  ChrisF Mar 3 '11 at 21:48

2 Answers 2

up vote 1 down vote accepted

I think you are experiencing one or more of the following problems:

  • the main mysql process is not running when you try to execute queries
  • your connection string or credentials are incorrect
  • the setup did not complete

Usually, individuals who install MySQL also install Apache as well as a LAMP php/apache server. XAMPP is super easy and fast. You can install MySQL individually, or alongside Apache, PHP, etc all at once.

share|improve this answer
    
even if I'm not going to use php at all?? I want to create a web application based on ruby on rails –  Bea Mar 3 '11 at 21:18

I suspect the service isn't started.

run services.msc and check if MySQL is listed and what its status is.

You might have it set to 'manual' as well. Setting it to 'automatic' will fire it up when you start the system up.

That's the exact error I get if I stop the service.

I suppose it could be a firewall issue too, but check the service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.