Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try installing a perl module on my system, it fails to install the dependencies. I had this working before, I'm not sure why it's not working on my fresh setup.

For example, I try to install Catalyst-Runtime-5.80032 (I downloaded from ).

Inside the directory, I type perl Makefile.PL. That comes back with

Warning: prerequisite B::Hooks::EndOfScope 0.08 not found.
Warning: prerequisite CGI::Simple::Cookie 1.109 not found.
Warning: prerequisite Class::C3::Adopt::NEXT 0.07 not found.
Warning: prerequisite Class::Data::Inheritable 0 not found.

along with other modules not found. Then I type make and all of the modules come back with errors.

*** Installing dependencies...
*** Installing Class::Data::Inheritable...
*** Could not find a version 0 or above for Class::Data::Inheritable; skipping.
*** Installing Test::Exception...
*** Could not find a version 0 or above for Test::Exception; skipping.
*** Installing namespace::autoclean...
*** Could not find a version 0.09 or above for namespace::autoclean; skipping.
*** Installing namespace::clean...
*** Could not find a version 0.13 or above for namespace::clean; skipping.
*** Installing B::Hooks::EndOfScope...
*** Could not find a version 0.08 or above for B::Hooks::EndOfScope; skipping.

and a whole bunch of others like that.

Any ideas why this is failing? I am behind a company firewall, but I have set up the http_proxy, ftp_proxy, and https_proxy environment variables in bash. I'm able to curl and wget from all these protocols.


share|improve this question
up vote 2 down vote accepted

Instead of manual building, which doesn't download dependencies (you have to do that manually to), why not use the cpan utility?

# cpan Catalyst::Runtime

That will download the package, it's dependencies, do all the compilation, and even install it all for you.

share|improve this answer
Hey, so when I try that it says Catalyst::Runtime is up to date (5.80032). But then if I try to do it manually again, it doesn't work. Shouldn't it work now if I try it manually since cpan Catalyst::Runtime should have installed all the dependencies? – mark Mar 4 '11 at 0:13
Your initial attempts at building manually have probably confused cpan somehow. Try running cpan on each of the listed dependencies then building the Catalyst Runtime again. All future builds should be done entirely with the cpan program. – Majenko Mar 4 '11 at 9:01
Thanks, I started over again with cpan and it works now! A couple of things that helped a lot: before installing run cpan. At the prompt 'o conf init'. Then I preferred to set o conf build_requires_install_policy yes and o conf prerequisites_policy follow. Then I ran cpan -if Catalyst::Runtime. – mark Mar 5 '11 at 21:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .