Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use 4 monitors but the videocards have outpus only for 2 video cards.

is there a way to work on one computer but use the monitor of another computer as an extension of the windows space.

kind of like synergy but in addition i want to share the window manager so that all programs lunch on the original computer. the second computer is old and not as powerful.

share|improve this question
    
this post is similar but it's for windows superuser.com/questions/94448/… –  kirill_igum Mar 4 '11 at 0:19
    
I realize that i can just use synergy and "ssh -X" but i would also like to be able to bring a window over to another machine –  kirill_igum Mar 4 '11 at 0:22

1 Answer 1

Take a look at Xdmx.

Say you are running Xdmx on a machine called x0 and you have two other machines available, x1 and x2, both of which have X servers running on them (i.e., you have logged into the console on x1 and x2 and are running an X session). To start Xdmx, use the following command:

Xdmx :1 +xinerama -display x1:0 -display x2:0

There should now be an X server running on x0 with the DISPLAY name ":1" (or, "x0:1"). The displays on x1 and x2 provide a unified input display, and the mouse on x1 should be able to move the cursor from x1 to x2 and back again. You can now set up applications to run on ":1", with the output being displayed on the x1 and x2 displays.

To include the local display, prepend another -display option naming the local display device (that is, :0).

share|improve this answer
    
Hi, looks like what i was looking for. but i get an error:"(Fatal Error) dmx: dmxOpenDisplay: Unable to open display dhcp-187-122.chem.rochester.edu:0" –  kirill_igum Mar 4 '11 at 2:48
    
i also followed this yolinux.com/HOWTO/Remote-X-Apps.html#s9 and tried: "xfig -display dhcp-187-122.chem.rochester.edu:0" and got an error Error: Can't open display: dhcp-187-122.chem.rochester.edu:0 . ssh -X works fine though –  kirill_igum Mar 4 '11 at 3:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.