Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The mouse scroll wheel does not work when not in copy mode. I'm not sure whether it is supposed to be working then? When in copy mode, the scroll wheel does work. The problem is that I still need to enter copy mode manually. Is it possible to enter copy mode upon mouse wheel activity? I am using gnome-terminal and the CVS version of tmux. These are my relevant settings:

set -g mouse-select-pane on
setw -g mode-mouse on
share|improve this question
    
Are you expecting the wheel to scroll the tmux buffer, or the program's window? (vim, for example, uses the wheel to scroll the document.) – grawity Mar 5 '11 at 19:21
    
I am expecting to scroll the tmux buffer. – Ton van den Heuvel Mar 5 '11 at 19:47
up vote 5 down vote accepted

In case people are still wondering, entering copy mode on mouse scroll is the default behaviour now in the development version of tmux.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .