Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using synergy to share keyboard/mouse between OSX and Win7.

Unfortunately for the mac, the commandkey seems to be bound to the alt key. How do I move it back to the command key? Or the ctrl key?

share|improve this question

Change the assignment in the Synergy configuration:

shift = {shift|ctrl|alt|meta|super|none}
ctrl = {shift|ctrl|alt|meta|super|none}
alt = {shift|ctrl|alt|meta|super|none}
meta = {shift|ctrl|alt|meta|super|none}
super = {shift|ctrl|alt|meta|super|none}

Map a modifier key pressed on the server's keyboard to a different modifier on this client. This option only has an effect on a client screen; it's accepted and ignored on the server screen.

You can map, say, the shift key to shift (the default), ctrl, alt, meta, super or nothing. Normally, you wouldn't remap shift or ctrl. You might, however, have an X11 server with meta bound to the Alt keys. To use this server effectively with a windows client, which doesn't use meta but uses alt extensively, you'll want the windows client to map meta to alt (using meta = alt).

If you don't know how to configure synergy via configuration files and use a Mac as host system, download and install SynergyKM, which provides a GUI-based configuration to Synergy.

Open System Preferences » SynergyKM, select Share my keyboard and mouse, and in the Server Configuration, add a screen for your Windows system and open Screen Options. Change your modifier key configuration there.

enter image description here

share|improve this answer
Am I supposed to understand that? – Mark Mar 5 '11 at 14:34

I don't see where you specified which machine is your host.

If you are using the Win7 machine as host, then the following configuration is what I use to make the keys work properly on the Mac client if you are using the text configuration:

section: screens
        alt = meta
        meta = super
        super = alt
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .