Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Mac OS X Server 10.6.0 in VMWare Fusion the other night and it worked perfectly, until I ran Software Update. I upgraded to 10.6.6 through the combo updater, and now when I start the VM it says:

"The CPU has been disabled by the guest operating system. You will need to power off or reset the virtual machine at this point."

I've switched the operating system in the options to OS X Server 32bit, 64bit, and even to Windows 7, and nothing has worked. Does anyone have any ideas?

share|improve this question

migrated from serverfault.com Mar 5 '11 at 13:14

This question came from our site for professional system and network administrators.

    
Is this vm running on mac hardware? –  egorgry Mar 5 '11 at 1:22
    
Yep. VMware Fusion 3.1.2 on a MBP early 2011. –  wjl Mar 5 '11 at 2:22
2  
@wjlafrance, VMWare is a company with over 40 different products, don't just use their name in future questions, use the product name. It's also not really a serverfault type question so I'm moving it to our sister site superuser.com. –  Chopper3 Mar 5 '11 at 13:13
    
What does vmware support say about this? –  Thorbjørn Ravn Andersen Jan 31 '12 at 7:46
add comment

3 Answers 3

If you have more than 1 CPU assigned to the VM instance try setting the number of CPU's to 1.

Other than that, make sure you have USB 2.0 support enabled. Sounds wierd, but it can cause this exact problem (ref: VMWare Fusion Rel. Notes

share|improve this answer
    
Hm, thanks for the attempt but I set it to "Mac OS X Server 10.6" as well as it's 64-bit counterpart, 1 processor, USB2.0. Same issue. Weird! –  wjl Mar 5 '11 at 4:53
add comment

Try reinstalling vmware fusion. It could have had a library issue which isn't uncommon on a Mac. Also running a permission repair after an upgrade can help clear up issues like this when a resource file can become incorrectly permissioned.

share|improve this answer
    
Thanks, but no dice. Did a permissions check, no fix. Reinstalled VMware, no fix. :( –  wjl Mar 5 '11 at 21:02
add comment

This isn't what you're looking for, but you should be able to use the image under VirtualBox 4.0 - it can read VMware's .VMDK files, and it can run OS X Server. I'm currently using 10.6.6 under VBox. (it's slower than VMWare for some stuff, though - be warned)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.