Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed Sql Server and it needed IIS.

Now when I go to http://localhost/ I get

-2147467259 (0x80004005)

I bet its IIS. How to turn it off and remove it from autostart?

share|improve this question

migrated from stackoverflow.com Mar 5 '11 at 16:30

This question came from our site for professional and enthusiast programmers.

    
What does it have to do with C#? –  muratgu Mar 5 '11 at 16:30

2 Answers 2

up vote 4 down vote accepted

SQL Server only requires IIS if you are installing the Reporting Services functionality as well. If you don't plan on using Reporting Services, then I would remove that feature from for SQL Server installation. Then you can remove IIS.

To remove IIS, it varies depending on Operating System. It's a system component, so in Windows 7 it would be Control Panel, Programs and Features, then on the side "Turn Windows Features on or off", and uncheck IIS.

EDIT:

To change the port, open a Run dialog and type "inetmgr", right click "Default Web Site" under Sites, and select "Edit Bindings". Select the "http" binding, click "Edit", and change the port. Or, you can removing the binding entirely. Going one step further, you can remove the Default Web Site all together.

share|improve this answer
    
i don't want to remove it, just stop it from running and blocking port 80. –  IAdapter Mar 5 '11 at 16:30
    
Answer updated. –  vcsjones Mar 5 '11 at 16:34

0x80004005 is a unspecified error, check your event log and IIS logs for more information.


Just disable and stop the World Wide Web Publishing Service:

sc config w3svc start= disabled
net stop w3svc

If you don't want it disabled, but manual instead, replace disabled by demand (don't remove space).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.