Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, this one is doing my head in...

I have just bought and installed a Netgear DGN2200 Wireless-N router, and it's all working find, but I can't get one laptop to communicate with it using WPA2.

All the other computers are working fine:

  • Ubuntu + Netgear WN111v2
  • Windows 7 + RTL8191SE
  • FreeBSD + RTL8192E
  • HTC Wildfire

All perfect.

The one that won't connect is Windows XP SP3 with an Atheros AR5007EG card.

It connects and works fine with encryption turned off (I actually have 2 SSIDs set up on the router - one encrypted and one open but isolated)

Connecting to the encrypted SSID it appears to authenticate with the WPA2 PSK, but then takes forever acquiring an IP address. It appears eventually to fail and then suddenly instantly succeed. The IP it gets is a valid one from the router.

But, I am unable to ping, or anything, on the network.

Atheros diagnostics are telling me there are lots of packets being retransmitted and lots of CRC errors in reception.

I'm thinking I may just go and try my Ubuntu Live CD to see if I can connect OK with that...

Oh, before you ask, yes, Windows Updates are all up to date, and I have just installed the latest Atheros drivers and client utility (first thing I tried).

It just defies logic (or I just need a fresh brain to mention the obvious - whatever that is)

Oh, and I know it's not the Netgear router - I have FreeBSD embedded machine with an Atheros card in it that I am running in HostAP mode with WPA2 and the laptop is exhibiting the same symptoms when trying to connect to that.


UPDATE

Ok, so I am posting this update from my Ubuntu Live CD on the offending laptop. It connected in about 1 second - maybe less ;)

So it looks like it may be the driver - I have that on a USB key to try next...


UPDATE

The driver update doesn't work with this card unfortunately.


UPDATE

Ok, get this...

If I set up a second SSID on the router using the exact same settings as the primary one, I can connect perfectly with WPA2.

share|improve this question
    
I know this question is 2 years old, so that's why I'm reacting via comment and not as an answer: I had EXACTLY this problem, with the same hardware :). The trick for me was to update the driver, which you state doesn't work. I used the driver from here: atheros.cz/… Which at this time is version: xp3264-10.0.0.216-whql.zip. After that everything functioned. How did you solve it eventually? Just stay with the second SSID? –  Yuri Sep 8 '13 at 10:47

2 Answers 2

You probably have neighbours nearby with wireless routers all using the same channel (most routers default to channel 6). Try switching to a different channel (to use different frequencies) and see if that helps.

  Network Stumbler
  http://www.netstumbler.com/

You can use Network Stumbler to find out what channels all the wireless routers in your area are using, which can be helpful in selecting one that's not being used.

share|improve this answer
    
Nope - tried other channels and it's exactly the same. –  Majenko Mar 5 '11 at 18:26

If the thread Getting Atheros AR5212 Wireless Cards to Work with Windows XP relates to your problem, then the solution there was to use the AWLC4030 Driver v4.0.0.1733.

share|improve this answer
    
Nope - it's not that Atheros card. It's an AR5007EG. The drivers on that site don't work with it. –  Majenko Mar 5 '11 at 18:23
    
Which version of driver are you using ? The latest one I can find for AR5007EG on XP is 9.1.0.323. However, from your latest update I understand that the problem is solved. And why down-vote my answer? –  harrymc Mar 5 '11 at 20:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.